summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorliberodark2018-04-26 18:21:35 +0200
committerliberodark2018-04-26 18:21:35 +0200
commitd1f9bbf4bea76b32d93b8131c8dcd481ac2c68f4 (patch)
treee941726f2c30764bbf50fbb9667f7e7e0edafa81
parentaa4d6464129ca1782e0ba0b0d627e824162ccbcd (diff)
downloadaur-d1f9bbf4bea76b32d93b8131c8dcd481ac2c68f4.tar.gz
Modif....
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
-rw-r--r--odrive-bin.desktop14
3 files changed, 18 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31a3c9cf63f5..58d58d42c0e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
# Generated by mksrcinfo v8
-# Tue Jan 2 12:37:17 UTC 2018
+# Thu Apr 26 16:21:22 UTC 2018
pkgbase = odrive-bin
pkgdesc = Google Drive GUI
- pkgver = 0.1.2
- pkgrel = 2
+ pkgver = 0.2.0
+ pkgrel = 1
url = https://github.com/liberodark/ODrive
arch = x86_64
license = GPL
depends = xdg-utils
source = odrive-bin.desktop
source = odrive-bin.png
- sha512sums = 37059f82eaed9f22a0cffa621a6a9d08410c6dfb37dddbc33db7e7cbd5c2008b152d4cc909b229dc9b4657135c01e3f97cff4409556b253014ac52833b794e4a
+ sha512sums = c5d47525f7410a732636a789e54ad70a3a29742d1cc5b869c5ad9a3e9b05575e1c73f953ca1ad35e4aaf3432ee5c9ae182e9e4c914ef5211fa106a577054686e
sha512sums = e852e6ee2714900b2b484dbe3f9bb69e72895391fed5e6776142c48daaf7e75a8a12908812894e5695277447bd2704cad93cd4f2ed0940ef45008e93b8823dd1
- source_x86_64 = https://github.com/liberodark/ODrive/releases/download/0.1.2/odrive-linux-x64.tar.gz
- sha512sums_x86_64 = e18d1141f32875f139aeb1327e2a298f71b01e721b72621d560b2d7e5a251197897dc93d10988067b70e2fa9368029aaba2c7cd564562f528522d5a1187c00e1
+ source_x86_64 = https://github.com/liberodark/ODrive/releases/download/v0.2.0/odrive_0.2.0_amd64.deb
+ sha512sums_x86_64 = e3681d0af651dfaaf5d4a76a38cf50b6c71b5930e97edd2ac7a6fbff04b1a99a4b2f3c8612ea8ab6229b49e0dd2df8f5d02015d1aa1cd8def1683afddf1e903d
pkgname = odrive-bin
diff --git a/PKGBUILD b/PKGBUILD
index 8c90ccb00b04..b5b131e4b73e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
# Maintainer: liberodark
pkgname=odrive-bin
-pkgver=0.1.2
-pkgrel=2
+pkgver=0.2.0
+pkgrel=1
pkgdesc="Google Drive GUI"
arch=('x86_64')
url="https://github.com/liberodark/ODrive"
license=('GPL')
depends=('xdg-utils')
-source_x86_64=("https://github.com/liberodark/ODrive/releases/download/${pkgver}/odrive-linux-x64.tar.gz")
+source_x86_64=("https://github.com/liberodark/ODrive/releases/download/v${pkgver}/odrive_${pkgver}_amd64.deb")
source=($pkgname.desktop
$pkgname.png)
-sha512sums=('37059f82eaed9f22a0cffa621a6a9d08410c6dfb37dddbc33db7e7cbd5c2008b152d4cc909b229dc9b4657135c01e3f97cff4409556b253014ac52833b794e4a'
+sha512sums=('c5d47525f7410a732636a789e54ad70a3a29742d1cc5b869c5ad9a3e9b05575e1c73f953ca1ad35e4aaf3432ee5c9ae182e9e4c914ef5211fa106a577054686e'
'e852e6ee2714900b2b484dbe3f9bb69e72895391fed5e6776142c48daaf7e75a8a12908812894e5695277447bd2704cad93cd4f2ed0940ef45008e93b8823dd1')
-sha512sums_x86_64=('e18d1141f32875f139aeb1327e2a298f71b01e721b72621d560b2d7e5a251197897dc93d10988067b70e2fa9368029aaba2c7cd564562f528522d5a1187c00e1')
+sha512sums_x86_64=('e3681d0af651dfaaf5d4a76a38cf50b6c71b5930e97edd2ac7a6fbff04b1a99a4b2f3c8612ea8ab6229b49e0dd2df8f5d02015d1aa1cd8def1683afddf1e903d')
package() {
cd $srcdir
- tar xvf odrive-linux-x64.tar.gz
- mkdir -p "$pkgdir/usr/share/odrive"
- cp -r "odrive-linux-x64/." "$pkgdir/usr/share/odrive"
- chmod 755 -R "$pkgdir/usr/share/odrive/resources/app"
+ tar xvf data.tar.xz
+ cp -r opt $pkgdir
install -vDm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
install -vDm644 $srcdir/$pkgname.png $pkgdir/usr/share/pixmaps/$pkgname.png
}
diff --git a/odrive-bin.desktop b/odrive-bin.desktop
index e5371dc5a439..c8426d924916 100644
--- a/odrive-bin.desktop
+++ b/odrive-bin.desktop
@@ -1,12 +1,8 @@
[Desktop Entry]
-Name=ODrive
-GenericName=Google Drive
-Comment=Google Drive GUI
-Exec=/usr/share/odrive/odrive
-Icon=odrive-bin
+Name=Open Drive
+Comment=Simple google drive client
+Exec="/opt/Open Drive/odrive" %U
Terminal=false
Type=Application
-Keywords=odrive;google;drive;
-Type=Application
-Categories=Network;FileTransfer;
-Version=1.0
+Icon=odrive
+Categories=Archiving;