summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Cochrane2019-05-28 09:41:21 +1200
committerAdrian Cochrane2019-05-28 09:41:21 +1200
commit9c77d0a9c5f90bfbd20baad974251941fba35735 (patch)
tree11a1cc72bfff289864b0e663191585f6ce1f9fba
downloadaur-9c77d0a9c5f90bfbd20baad974251941fba35735.tar.gz
Commit Arch packaging for Odysseus.
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD43
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee685c6a7bf6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = odysseus
+ pkgdesc = Web browser for the open and decentralized web.
+ pkgver = 1.5.18
+ pkgrel = 1
+ url = https://odysseus.adrian.geek.nz
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = meson
+ makedepends = vala
+ depends = gtk3
+ depends = granite
+ depends = webkit2gtk
+ depends = json-glib
+ depends = libsoup
+ depends = sqlite
+ depends = appstream
+ depends = gcr
+ depends = gettext
+ optdepends = archlinux-appstream-data: compatible app recommendations for hyperlinks
+ optdepends = html-xml-utils: webfeed autodiscovery
+ source = https://github.com/alcinnz/Odysseus/archive/1.5.18.tar.gz
+ md5sums = 939f5f1811359a00146a6e0c7105f547
+
+pkgname = odysseus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e5553b6e3f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Adrian Cochrane <alcinnz@lavabit.com>
+pkgname=odysseus
+pkgver=1.5.18
+pkgrel=1
+pkgdesc="Web browser for the open and decentralized web."
+url="https://odysseus.adrian.geek.nz"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=(
+ 'gtk3'
+ 'granite'
+ 'webkit2gtk'
+ 'json-glib'
+ 'libsoup'
+ 'sqlite'
+ 'appstream'
+ 'gcr'
+ 'gettext'
+)
+makedepends=(
+ 'meson'
+ 'vala'
+)
+optdepends=(
+ 'archlinux-appstream-data: compatible app recommendations for hyperlinks'
+ 'html-xml-utils: webfeed autodiscovery'
+)
+source=(https://github.com/alcinnz/Odysseus/archive/$pkgver.tar.gz)
+md5sums=(939f5f1811359a00146a6e0c7105f547) #autofill using updpkgsums
+
+build() {
+ cd "Odysseus-$pkgver"
+
+ [ -d build ] && rm -rf build
+ meson build --prefix=/usr --buildtype=release
+ ninja -C build
+}
+
+package() {
+ cd "Odysseus-$pkgver"
+
+ DESTDIR="$pkgdir" ninja -C build install
+}