summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Tia2015-07-27 21:53:55 -0600
committerJavier Tia2015-07-27 21:53:55 -0600
commitaeb19be0403a624318df9fd7a33a0fb9cb13ca0f (patch)
tree882f40c3b96f69429f809b41f8297922b2875785
downloadaur-aeb19be0403a624318df9fd7a33a0fb9cb13ca0f.tar.gz
Initial Office Code Pro package release
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
-rw-r--r--office-code-pro.install14
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8531f39c3e39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = office-code-pro
+ pkgdesc = Office Code Pro is a customized version of Source Code Pro for text editors and coding environments
+ pkgver = 1.004
+ pkgrel = 1
+ url = https://github.com/nathco/Office-Code-Pro
+ install = office-code-pro.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = https://github.com/nathco/Office-Code-Pro/archive/1.004.tar.gz
+ sha256sums = 9bca923d17f6c47a586d8e4567d46ccfa58fb8b8e2247b5ee2a19da1597c58f6
+
+pkgname = office-code-pro
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6a144c4001e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Javier Tia <javier.tia@gmail.com>
+pkgname=office-code-pro
+_srcname=Office-Code-Pro
+pkgver=1.004
+pkgrel=1
+depends=(fontconfig xorg-font-utils)
+pkgdesc="Office Code Pro is a customized version of Source Code Pro for text editors and coding environments"
+url="https://github.com/nathco/Office-Code-Pro"
+license=(custom)
+arch=(any)
+
+source=("https://github.com/nathco/$_srcname/archive/$pkgver.tar.gz")
+sha256sums=('9bca923d17f6c47a586d8e4567d46ccfa58fb8b8e2247b5ee2a19da1597c58f6')
+
+install=$pkgname.install
+
+package() {
+ install -Dm644 $srcdir/$_srcname-$pkgver/LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ install -d "$pkgdir/usr/share/fonts/OTF/"
+ cd $srcdir/$_srcname-$pkgver/Fonts/Office\ Code\ Pro/OTF/
+ install -t "$pkgdir/usr/share/fonts/OTF/" -m644 *.otf
+
+ cd $srcdir/$_srcname-$pkgver/Fonts/Office\ Code\ Pro\ D/OTF/
+ install -t "$pkgdir/usr/share/fonts/OTF/" -m644 *.otf
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/office-code-pro.install b/office-code-pro.install
new file mode 100644
index 000000000000..79c6030606fa
--- /dev/null
+++ b/office-code-pro.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo Updating font cache...
+ fc-cache >/dev/null -f
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}