summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-12-10 07:27:55 +1300
committercaltlgin2020-12-10 07:27:55 +1300
commite700ab44101e738c432258cadba9a8dab8e8cdac (patch)
tree85dcbc261a82a64494a3c279ab4f7b308b594dc0
parent044cd42c0169e8cc59899d4142623ddf9e45c412 (diff)
downloadaur-e700ab44101e738c432258cadba9a8dab8e8cdac.tar.gz
Refactored PKGBUILD
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 7 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 9073a1933932..42d3f0003b88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,10 @@
# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
# Contributor: Javier Tia <javier.tia@gmail.com>
-_pkgname=Office-Code-Pro
-pkgname=${_pkgname,,}
+# otfinfo --info *.otf
+
+_pkgname='Office-Code-Pro'
+pkgname="${_pkgname,,}"
pkgver=1.004
pkgrel=3
pkgdesc='Customized version of Source Code Pro font'
@@ -14,10 +16,9 @@ sha256sums=('9bca923d17f6c47a586d8e4567d46ccfa58fb8b8e2247b5ee2a19da1597c58f6')
package() {
cd "${_pkgname}-${pkgver}"
- install -Dm644 -t "${pkgdir}/usr/share/fonts/OTF" "Fonts/${_pkgname//-/ }/OTF/"*.otf
- install -Dm644 -t "${pkgdir}/usr/share/fonts/OTF" "Fonts/${_pkgname//-/ } D/OTF/"*.otf
- install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md'
- install -Dm644 'LICENSE.txt' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ find 'Fonts' -type f -name "*.otf" -exec install -Dvm644 "{}" -t "${pkgdir}/usr/share/fonts/OTF" \;
+ install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 'LICENSE.txt' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-# vim:set ts=2 sw=2 et:
+# vim: ts=2 sw=2 et: