summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Van Loon2022-09-08 12:15:57 +0200
committerBart Van Loon2022-09-08 12:15:57 +0200
commita1cf2de0345eb024ed25b1c83cbf066555202d43 (patch)
tree8ac057049f01b928d0d2c8fe6c80ca7657ff21a0
parente3a19b22e3d2b36670159e4e7984e8601a4f5c48 (diff)
downloadaur-a1cf2de0345eb024ed25b1c83cbf066555202d43.tar.gz
apparently a little hack was needed to get poetry to include the python
files into the wheel
-rw-r--r--PKGBUILD3
-rwxr-xr-xupdate.sh3
2 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9839a8c10fe3..fb9a112d722d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,8 @@ replaces=('python-offlinemsmtp')
build() {
cd "${srcdir}/${_module}-${pkgver}"
- poetry build
+ sed -i '/keywords.*/ainclude = [ { path = "offlinemsmtp/*" } ]' pyproject.toml
+ poetry build --format=wheel
}
package() {
diff --git a/update.sh b/update.sh
index f038d5e4e1d0..8a564d360338 100755
--- a/update.sh
+++ b/update.sh
@@ -65,7 +65,8 @@ ${ADDITIONAL}
build() {
cd \"\${srcdir}/\${_module}-\${pkgver}\"
- poetry build
+ sed -i '/keywords.*/ainclude = [ { path = \"offlinemsmtp/*\" } ]' pyproject.toml
+ poetry build --format=wheel
}
package() {