summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenneth Endfinger2020-01-23 13:46:20 -0500
committerKenneth Endfinger2020-01-23 13:46:20 -0500
commitdd0d32ccc8125396d796b2f91eb738f0f18110eb (patch)
treed4081e89c10f875d654f95d20b5adb7785a9a37b
parentaae29ed468ff6bc2a595f80f4c16950c554dd67e (diff)
downloadaur-dd0d32ccc8125396d796b2f91eb738f0f18110eb.tar.gz
Add a check-for-update script, and add support for more architectures.
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD7
-rwxr-xr-xcheck-for-update.sh15
4 files changed, 30 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 435204dcab81..33c21329d1b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,13 @@
pkgbase = ofono
pkgdesc = Infrastructure for building mobile telephony (GSM/UMTS) applications
pkgver = 1.31
- pkgrel = 1
+ pkgrel = 2
url = https://01.org/ofono
+ arch = i686
arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = GPL2
depends = bluez
depends = dbus
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9e7de4264dad
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+/src
+/pkg
+*.xz
+*.tar.*
+*.pkg.*
+*.zip
+*.zip.sig
diff --git a/PKGBUILD b/PKGBUILD
index 69f281f9acd5..84cd54874474 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Jerome Leclanche <jerome@leclan.ch>
-
+# Contributor: Kenneth Endfinger <kaendfinger@gmail.com>
pkgname=ofono
pkgver=1.31
-pkgrel=1
+pkgrel=2
pkgdesc="Infrastructure for building mobile telephony (GSM/UMTS) applications"
url="https://01.org/ofono"
-arch=("x86_64")
+arch=("i686" "x86_64" "armv6h" "armv7h" "aarch64")
license=("GPL2")
depends=("bluez" "dbus" "modemmanager" "glib2" "udev" "mobile-broadband-provider-info")
source=(
@@ -20,7 +20,6 @@ validpgpkeys=(
"E932D120BC2AEC444E558F0106CA9F5D1DCF2659" # Marcel Holtmann <marcel@holtmann.org>
)
-
build() {
cd "$srcdir/$pkgname-$pkgver"
./configure \
diff --git a/check-for-update.sh b/check-for-update.sh
new file mode 100755
index 000000000000..37d0b674b243
--- /dev/null
+++ b/check-for-update.sh
@@ -0,0 +1,15 @@
+#!/usr/bin/env bash
+set -e
+
+cd $(dirname "${0}")
+
+PKG=$(cat .SRCINFO | grep "pkgbase" | head -n1 | awk '{print $3}')
+CURRENT=$(cat .SRCINFO | grep "pkgver" | head -n1 | awk '{print $3}')
+LATEST=$(curl --silent 'https://git.kernel.org/pub/scm/network/ofono/ofono.git/info/refs' | grep "refs/tags" | grep -F -v "^{}" | awk -F'/' '{print $3}' | sort --version-sort | tail -n1)
+if [ "${LATEST}" != "${CURRENT}" ]
+then
+ echo "${PKG} : AUR ${CURRENT} != Upstream ${LATEST}"
+ exit 1
+fi
+echo "${PKG} : AUR ${CURRENT} == Upstream ${LATEST}"
+exit 0