summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibrewish2020-11-12 10:31:28 +0530
committerlibrewish2020-11-12 10:31:28 +0530
commitf466123f25a0c43ff9de15ba82153f5ec8e50237 (patch)
tree9efe290d1e7cc146b272284400f93fa95dae9653
parent2552d3b6167111c7f4977901809bdb35e16b8db5 (diff)
downloadaur-f466123f25a0c43ff9de15ba82153f5ec8e50237.tar.gz
update
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 19 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33c21329d1b1..3b9edf8fa2c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,20 @@
pkgbase = ofono
pkgdesc = Infrastructure for building mobile telephony (GSM/UMTS) applications
pkgver = 1.31
- pkgrel = 2
+ pkgrel = 3
url = https://01.org/ofono
- arch = i686
- arch = x86_64
- arch = armv6h
- arch = armv7h
- arch = aarch64
+ arch = any
license = GPL2
depends = bluez
depends = dbus
- depends = modemmanager
depends = glib2
depends = udev
depends = mobile-broadband-provider-info
+ optdepends = phonesim
+ optdepends = mmsd
+ optdepends = upower
source = https://www.kernel.org/pub/linux/network/ofono/ofono-1.31.tar.xz
- source = https://www.kernel.org/pub/linux/network/ofono/ofono-1.31.tar.sign
- validpgpkeys = E932D120BC2AEC444E558F0106CA9F5D1DCF2659
sha256sums = a15c5d28096c10eb30e47a68b6dc2e7c4a5a99d7f4cfedf0b69624f33d859e9b
- sha256sums = SKIP
pkgname = ofono
diff --git a/PKGBUILD b/PKGBUILD
index 84cd54874474..b5abf8d941da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,34 @@
# Maintainer: Jerome Leclanche <jerome@leclan.ch>
# Contributor: Kenneth Endfinger <kaendfinger@gmail.com>
+# Contributor: Librewish <librewish@gmail.com>
pkgname=ofono
pkgver=1.31
-pkgrel=2
+pkgrel=3
pkgdesc="Infrastructure for building mobile telephony (GSM/UMTS) applications"
url="https://01.org/ofono"
-arch=("i686" "x86_64" "armv6h" "armv7h" "aarch64")
+arch=("any")
license=("GPL2")
-depends=("bluez" "dbus" "modemmanager" "glib2" "udev" "mobile-broadband-provider-info")
+depends=("bluez" "dbus" "glib2" "udev" "mobile-broadband-provider-info")
+optdepends=("phonesim" "mmsd" "upower")
source=(
"https://www.kernel.org/pub/linux/network/ofono/$pkgname-$pkgver.tar.xz"
- "https://www.kernel.org/pub/linux/network/ofono/$pkgname-$pkgver.tar.sign"
-)
-sha256sums=(
- "a15c5d28096c10eb30e47a68b6dc2e7c4a5a99d7f4cfedf0b69624f33d859e9b"
- "SKIP"
-)
-validpgpkeys=(
- "E932D120BC2AEC444E558F0106CA9F5D1DCF2659" # Marcel Holtmann <marcel@holtmann.org>
+# "https://www.kernel.org/pub/linux/network/ofono/$pkgname-$pkgver.tar.sign"
)
+sha256sums=('a15c5d28096c10eb30e47a68b6dc2e7c4a5a99d7f4cfedf0b69624f33d859e9b'
+# 'SKIP'
+ )
build() {
cd "$srcdir/$pkgname-$pkgver"
./configure \
--prefix=/usr \
--sysconfdir=/etc \
+ --localstatedir=/var \
--sbindir=/usr/bin \
- --disable-bluez4
-
+ --mandir=/usr/share/man \
+ --enable-test \
+ --enable-tools \
+ --enable-dundee
make
}