summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-10-23 14:48:32 -0600
committerMark Wagie2021-10-23 14:48:32 -0600
commit146cf77559bf2727a502ec5414e9cb668308e687 (patch)
treef9570b62936c59ad43ad3fbbd7e0fad68ba9e7ce
parentac246ed4afd8cc0481e5c686e50da5e86186ac2d (diff)
downloadaur-146cf77559bf2727a502ec5414e9cb668308e687.tar.gz
add missing dependency, add PGP signature
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 463fa3532fc7..74c098252d90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ognibuild
pkgdesc = Detect and invoke build systems
pkgver = 0.0.9
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jelmer/ognibuild
arch = any
license = GPL2
@@ -9,7 +9,11 @@ pkgbase = ognibuild
depends = python-buildlog-consultant
depends = python-requirements-parser
depends = python-setuptools
+ depends = python-toml
source = https://pypi.org/packages/source/o/ognibuild/ognibuild-0.0.9.tar.gz
+ source = https://pypi.org/packages/source/o/ognibuild/ognibuild-0.0.9.tar.gz.asc
+ validpgpkeys = DC837EE14A7E37347E87061700806F2BD729A457
sha256sums = cc68b574c20676187688a31415a16b3bba7ba2e9ab7e6747255bf17767ab5ac2
+ sha256sums = SKIP
pkgname = ognibuild
diff --git a/PKGBUILD b/PKGBUILD
index 60410ecd561e..fc824584ee6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,17 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=ognibuild
pkgver=0.0.9
-pkgrel=1
+pkgrel=2
pkgdesc="Detect and invoke build systems"
arch=('any')
url="https://github.com/jelmer/ognibuild"
license=('GPL2')
depends=('breezy' 'python-buildlog-consultant' 'python-requirements-parser'
- 'python-setuptools')
-source=("https://pypi.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('cc68b574c20676187688a31415a16b3bba7ba2e9ab7e6747255bf17767ab5ac2')
+ 'python-setuptools' 'python-toml')
+source=("https://pypi.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"{,.asc})
+sha256sums=('cc68b574c20676187688a31415a16b3bba7ba2e9ab7e6747255bf17767ab5ac2'
+ 'SKIP')
+validpgpkeys=('DC837EE14A7E37347E87061700806F2BD729A457') # Jelmer Vernooij <jelmer@jelmer.uk>
build() {
cd "$pkgname-$pkgver"
@@ -18,7 +20,6 @@ build() {
package() {
cd "$pkgname-$pkgver"
- export PYTHONHASHSEED=0
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
# Remove Debian-specific binary