summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-05-15 12:37:45 -0600
committerMark Wagie2021-05-15 12:37:45 -0600
commit2222fd76afeb4d32fa9822263e4991f65d1171d8 (patch)
treeb19819b9658d9de489f2f333dfca595e796e7c0f
downloadaur-2222fd76afeb4d32fa9822263e4991f65d1171d8.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD31
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e418da4e9566
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ognibuild
+ pkgdesc = Detect and invoke build systems
+ pkgver = 0.0.4
+ pkgrel = 1
+ url = https://github.com/jelmer/ognibuild
+ arch = any
+ license = GPL2
+ makedepends = python-setuptools
+ depends = breezy
+ depends = dpkg
+ depends = python-apt
+ depends = python-buildlog-consultant
+ depends = python-debian
+ depends = python-requirements-parser
+ optdepends = python-debmutate
+ source = https://pypi.org/packages/source/o/ognibuild/ognibuild-0.0.4.tar.gz
+ sha256sums = 1f724c10dbcbcc84fe039d79bd18e44906fa2d6cc22b3db229cb5981f4473cad
+
+pkgname = ognibuild
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3b4c6aab08f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=ognibuild
+pkgver=0.0.4
+pkgrel=1
+pkgdesc="Detect and invoke build systems"
+arch=('any')
+url="https://github.com/jelmer/ognibuild"
+license=('GPL2')
+depends=('breezy' 'dpkg' 'python-apt' 'python-buildlog-consultant' 'python-debian'
+ 'python-requirements-parser')
+makedepends=('python-setuptools')
+#checkdepends=('python-debmutate' 'python-testtools')
+optdepends=('python-debmutate')
+source=("https://pypi.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('1f724c10dbcbcc84fe039d79bd18e44906fa2d6cc22b3db229cb5981f4473cad')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+#check() {
+# cd "$pkgname-$pkgver"
+# python setup.py test
+#}
+
+package() {
+ cd "$pkgname-$pkgver"
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}