summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-01-11 16:10:15 -0700
committerMark Wagie2023-01-11 16:10:15 -0700
commit9caa9942c401ac1fdd7c47909799160025a9f224 (patch)
tree9762c0686d3327149f3007c8b1b4a18f08034d1b
parent3a7071adc20da0520831772133f7789513e3317e (diff)
downloadaur-9caa9942c401ac1fdd7c47909799160025a9f224.tar.gz
0.0.17
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index adb0050e3136..cc20758f64f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = ognibuild
pkgdesc = Detect and invoke build systems
- pkgver = 0.0.16
+ pkgver = 0.0.17
pkgrel = 1
- url = https://jelmer.uk/code/ognibuild
+ url = https://github.com/jelmer/ognibuild
arch = any
license = GPL2
makedepends = python-build
@@ -14,10 +14,7 @@ pkgbase = ognibuild
depends = python-ruamel-yaml
depends = python-setuptools
depends = python-toml
- source = https://files.pythonhosted.org/packages/source/o/ognibuild/ognibuild-0.0.16.tar.gz
- source = https://files.pythonhosted.org/packages/source/o/ognibuild/ognibuild-0.0.16.tar.gz.asc
- validpgpkeys = DC837EE14A7E37347E87061700806F2BD729A457
- sha256sums = d594ae631b9621ac6753869a67b8cc2b7aaab62afa53db51a4de3d08a376a822
- sha256sums = SKIP
+ source = https://files.pythonhosted.org/packages/source/o/ognibuild/ognibuild-0.0.17.tar.gz
+ sha256sums = b0300a43dd7d75364736a78c4aa1c9d6101648164dbb31bc47c65788993568f7
pkgname = ognibuild
diff --git a/PKGBUILD b/PKGBUILD
index 83389cdba005..64ffab70d594 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=ognibuild
-pkgver=0.0.16
+pkgver=0.0.17
pkgrel=1
pkgdesc="Detect and invoke build systems"
arch=('any')
-url="https://jelmer.uk/code/ognibuild"
-#url="https://github.com/jelmer/ognibuild"
+#url="https://jelmer.uk/code/ognibuild"
+url="https://github.com/jelmer/ognibuild"
license=('GPL2')
depends=('breezy' 'python-buildlog-consultant' 'python-requirements-parser'
'python-ruamel-yaml' 'python-setuptools' 'python-toml')
makedepends=('python-build' 'python-installer' 'python-wheel')
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz"{,.asc})
-sha256sums=('d594ae631b9621ac6753869a67b8cc2b7aaab62afa53db51a4de3d08a376a822'
- 'SKIP')
-validpgpkeys=('DC837EE14A7E37347E87061700806F2BD729A457') # Jelmer Vernooij <jelmer@jelmer.uk>
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('b0300a43dd7d75364736a78c4aa1c9d6101648164dbb31bc47c65788993568f7')
+#validpgpkeys=('DC837EE14A7E37347E87061700806F2BD729A457') # Jelmer Vernooij <jelmer@jelmer.uk> (expired)
build() {
cd "$pkgname-$pkgver"
@@ -25,5 +24,5 @@ package() {
python -m installer --destdir="$pkgdir" dist/*.whl
# Remove Debian-specific binaries
- rm "$pkgdir"/usr/bin/{deb-fix-build,report-apt-deps-status}
+ rm "$pkgdir"/usr/bin/{deb-fix-build,deb-upstream-deps,report-apt-deps-status}
}