summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-11-06 07:57:07 -0700
committerMark Wagie2022-11-06 07:57:07 -0700
commita30977e4e00b9373954118a2c3038773ba423f78 (patch)
tree81cfe1024c0925460c22283e58f45344fd7c73e7
parent4c9d7de350ff7ba8341c16e517a90363d0ae6a20 (diff)
downloadaur-a30977e4e00b9373954118a2c3038773ba423f78.tar.gz
0.0.15
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f22f0865669..bb255727214e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = ognibuild
pkgdesc = Detect and invoke build systems
- pkgver = 0.0.14
- pkgrel = 2
- url = https://jelmer.uk/code/ognibuild
+ pkgver = 0.0.15
+ pkgrel = 1
+ url = https://github.com/jelmer/ognibuild
arch = any
license = GPL2
makedepends = python-build
@@ -11,9 +11,13 @@ pkgbase = ognibuild
depends = breezy
depends = python-buildlog-consultant
depends = python-requirements-parser
+ depends = python-ruamel-yaml
depends = python-setuptools
depends = python-toml
- source = https://files.pythonhosted.org/packages/source/o/ognibuild/ognibuild-0.0.14.tar.gz
- sha256sums = f8feefc9233a5b20cfe0d0562ed4709e20112671a17a8c752f2df334df88eb4a
+ source = https://files.pythonhosted.org/packages/source/o/ognibuild/ognibuild-0.0.15.tar.gz
+ source = https://files.pythonhosted.org/packages/source/o/ognibuild/ognibuild-0.0.15.tar.gz.asc
+ validpgpkeys = DC837EE14A7E37347E87061700806F2BD729A457
+ sha256sums = 8541c37a66853bfc0a3806b2a38bedc5246c12e22d2415775f1bf14f6b07b9a6
+ sha256sums = SKIP
pkgname = ognibuild
diff --git a/PKGBUILD b/PKGBUILD
index 6d133adbd1e1..9891dcf6380d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=ognibuild
-pkgver=0.0.14
-pkgrel=2
+pkgver=0.0.15
+pkgrel=1
pkgdesc="Detect and invoke build systems"
arch=('any')
-url="https://jelmer.uk/code/ognibuild"
-#url="https://github.com/jelmer/ognibuild"
+#url="https://jelmer.uk/code/ognibuild"
+url="https://github.com/jelmer/ognibuild"
license=('GPL2')
depends=('breezy' 'python-buildlog-consultant' 'python-requirements-parser'
- 'python-setuptools' 'python-toml')
+ 'python-ruamel-yaml' 'python-setuptools' 'python-toml')
makedepends=('python-build' 'python-installer' 'python-wheel')
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('f8feefc9233a5b20cfe0d0562ed4709e20112671a17a8c752f2df334df88eb4a')
-#validpgpkeys=('DC837EE14A7E37347E87061700806F2BD729A457') # Jelmer Vernooij <jelmer@jelmer.uk>
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz"{,.asc})
+sha256sums=('8541c37a66853bfc0a3806b2a38bedc5246c12e22d2415775f1bf14f6b07b9a6'
+ 'SKIP')
+validpgpkeys=('DC837EE14A7E37347E87061700806F2BD729A457') # Jelmer Vernooij <jelmer@jelmer.uk>
build() {
cd "$pkgname-$pkgver"