summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-09-10 13:48:53 -0600
committerMark Wagie2023-09-10 13:48:53 -0600
commitafcdea6850227cb49404febdebfac1d97b0def0b (patch)
tree751c2d2c5558922275803ba62c79726f05199364
parentb029723dd2911276b5323cb9fc1e6344e2278feb (diff)
downloadaur-afcdea6850227cb49404febdebfac1d97b0def0b.tar.gz
0.0.19
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dceb5b9704c1..589936d98e05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ognibuild
pkgdesc = Detect and invoke build systems
- pkgver = 0.0.18
- pkgrel = 2
+ pkgver = 0.0.19
+ pkgrel = 1
url = https://github.com/jelmer/ognibuild
arch = any
license = GPL2
@@ -14,9 +14,13 @@ pkgbase = ognibuild
depends = python-ruamel-yaml
depends = python-setuptools
depends = python-toml
+ optdepends = python-aiohttp-openmetrics
optdepends = python-apt
+ optdepends = python-debian
optdepends = python-debmutate
- source = https://files.pythonhosted.org/packages/source/o/ognibuild/ognibuild-0.0.18.tar.gz
- sha256sums = 8d16daa719503a1c1026ea3793c1b8c5f7ebd3dd9476d0223f828e736d521edf
+ optdepends = python-lz4
+ optdepends = python-psycopg2
+ source = ognibuild-0.0.19.tar.gz::https://github.com/jelmer/ognibuild/archive/refs/tags/v0.0.19.tar.gz
+ sha256sums = 04a167e20322387d5af077b66c76837a5491a1e21e77931566302e2067ed3080
pkgname = ognibuild
diff --git a/PKGBUILD b/PKGBUILD
index d215d2066f36..e3f13c2766e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=ognibuild
-pkgver=0.0.18
-pkgrel=2
+pkgver=0.0.19
+pkgrel=1
pkgdesc="Detect and invoke build systems"
arch=('any')
#url="https://jelmer.uk/code/ognibuild"
@@ -10,9 +10,15 @@ license=('GPL2')
depends=('breezy' 'python-buildlog-consultant' 'python-requirements-parser'
'python-ruamel-yaml' 'python-setuptools' 'python-toml')
makedepends=('python-build' 'python-installer' 'python-wheel')
-optdepends=('python-apt' 'python-debmutate')
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('8d16daa719503a1c1026ea3793c1b8c5f7ebd3dd9476d0223f828e736d521edf')
+optdepends=('python-aiohttp-openmetrics'
+ 'python-apt'
+# 'python-brz-debian'
+ 'python-debian'
+ 'python-debmutate'
+ 'python-lz4'
+ 'python-psycopg2')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/jelmer/ognibuild/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('04a167e20322387d5af077b66c76837a5491a1e21e77931566302e2067ed3080')
#validpgpkeys=('DC837EE14A7E37347E87061700806F2BD729A457') # Jelmer Vernooij <jelmer@jelmer.uk> (expired)
build() {