summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-02-07 18:00:45 -0700
committerMark Wagie2023-02-07 18:00:45 -0700
commitb029723dd2911276b5323cb9fc1e6344e2278feb (patch)
treef4d3c37da43042beb36c4fd10db41d27b46c0946
parent46adbec01b42a6bee575a40c6dfc7f6ef7f0a47e (diff)
downloadaur-b029723dd2911276b5323cb9fc1e6344e2278feb.tar.gz
don't remove files, add optional deps
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f4c99247ad9..dceb5b9704c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ognibuild
pkgdesc = Detect and invoke build systems
pkgver = 0.0.18
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jelmer/ognibuild
arch = any
license = GPL2
@@ -14,6 +14,8 @@ pkgbase = ognibuild
depends = python-ruamel-yaml
depends = python-setuptools
depends = python-toml
+ optdepends = python-apt
+ optdepends = python-debmutate
source = https://files.pythonhosted.org/packages/source/o/ognibuild/ognibuild-0.0.18.tar.gz
sha256sums = 8d16daa719503a1c1026ea3793c1b8c5f7ebd3dd9476d0223f828e736d521edf
diff --git a/PKGBUILD b/PKGBUILD
index 5badf3e5286b..d215d2066f36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=ognibuild
pkgver=0.0.18
-pkgrel=1
+pkgrel=2
pkgdesc="Detect and invoke build systems"
arch=('any')
#url="https://jelmer.uk/code/ognibuild"
@@ -10,6 +10,7 @@ license=('GPL2')
depends=('breezy' 'python-buildlog-consultant' 'python-requirements-parser'
'python-ruamel-yaml' 'python-setuptools' 'python-toml')
makedepends=('python-build' 'python-installer' 'python-wheel')
+optdepends=('python-apt' 'python-debmutate')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
sha256sums=('8d16daa719503a1c1026ea3793c1b8c5f7ebd3dd9476d0223f828e736d521edf')
#validpgpkeys=('DC837EE14A7E37347E87061700806F2BD729A457') # Jelmer Vernooij <jelmer@jelmer.uk> (expired)
@@ -22,7 +23,4 @@ build() {
package() {
cd "$pkgname-$pkgver"
python -m installer --destdir="$pkgdir" dist/*.whl
-
- # Remove Debian-specific binaries
- rm "$pkgdir"/usr/bin/{deb-fix-build,deb-upstream-deps,report-apt-deps-status}
}