summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-06-11 22:11:16 -0600
committerMark Wagie2021-06-11 22:11:16 -0600
commitcddd98846e4bbc70f66aaf3dac33d0dc30d14d39 (patch)
tree11aa4ae0649d0e8dfdf1cdf9cca5924522d85c40
parent9e16a7bcedee8f947cb9524bce6cbc4b00781bd5 (diff)
downloadaur-cddd98846e4bbc70f66aaf3dac33d0dc30d14d39.tar.gz
0.0.8
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD24
2 files changed, 11 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd25048f3556..addd4acbba96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ognibuild
pkgdesc = Detect and invoke build systems
- pkgver = 0.0.7+2+gdcf1a00
- pkgrel = 2
+ pkgver = 0.0.8
+ pkgrel = 1
url = https://github.com/jelmer/ognibuild
arch = any
license = GPL2
@@ -11,8 +11,7 @@ pkgbase = ognibuild
depends = python-buildlog-consultant
depends = python-requirements-parser
depends = python-setuptools
- source = git+https://github.com/jelmer/ognibuild.git#commit=dcf1a0079d40a261beb5fd738d56c151cbc4d7ef
- sha256sums = SKIP
+ source = https://pypi.org/packages/source/o/ognibuild/ognibuild-0.0.8.tar.gz
+ sha256sums = d8abf33097732ef879b4afed5eefda2d599ca34dd08f6fd3069080da5740ff3e
pkgname = ognibuild
-
diff --git a/PKGBUILD b/PKGBUILD
index a0353627bc80..82e4634f7b64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=ognibuild
-pkgver=0.0.7+2+gdcf1a00
-pkgrel=2
+pkgver=0.0.8
+pkgrel=1
pkgdesc="Detect and invoke build systems"
arch=('any')
url="https://github.com/jelmer/ognibuild"
@@ -10,31 +10,21 @@ depends=('breezy' 'python-buildlog-consultant' 'python-requirements-parser'
'python-setuptools')
makedepends=('git')
checkdepends=('python-testtools')
-#source=("https://pypi.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz")
-_commit=dcf1a0079d40a261beb5fd738d56c151cbc4d7ef
-source=("git+https://github.com/jelmer/ognibuild.git#commit=$_commit")
-sha256sums=('SKIP')
-
-pkgver() {
- cd "$srcdir/$pkgname"
- git describe --tags | sed 's/^v//;s/-/+/g'
-}
+source=("https://pypi.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('d8abf33097732ef879b4afed5eefda2d599ca34dd08f6fd3069080da5740ff3e')
build() {
-# cd "$pkgname-$pkgver"
- cd "$srcdir/$pkgname"
+ cd "$pkgname-$pkgver"
python setup.py build
}
check() {
-# cd "$pkgname-$pkgver"
- cd "$srcdir/$pkgname"
+ cd "$pkgname-$pkgver"
python setup.py test
}
package() {
-# cd "$pkgname-$pkgver"
- cd "$srcdir/$pkgname"
+ cd "$pkgname-$pkgver"
export PYTHONHASHSEED=0
python setup.py install --root="$pkgdir" --optimize=1 --skip-build