summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJerry Lin2018-11-09 08:08:51 +0800
committerJerry Lin2018-11-09 08:08:51 +0800
commit00cb32a2da44529c9825393bad954bfc5632214b (patch)
tree022e92674cc180f81067c63917c7ae206afa3962
downloadaur-00cb32a2da44529c9825393bad954bfc5632214b.tar.gz
Initial commit. Create PKGBUILD for pnorman's ogr2osm
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
-rw-r--r--setup.py25
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3583eb2bb3fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ogr2osm-git
+ pkgdesc = A tool for converting ogr-readable files like shapefiles into .osm data
+ pkgver = r141.4f5318b
+ pkgrel = 1
+ url = https://github.com/pnorman/ogr2osm
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = python-gdal
+ provides = ogr2osm
+ conflicts = ogr2osm
+ source = ogr2osm::git+https://github.com/pnorman/ogr2osm.git
+ source = setup.py
+ sha256sums = SKIP
+ sha256sums = 18049525bdc1d0c99d2863ac1d88b149e7dc9d4f2c521ff2e523c04bdc5f3961
+
+pkgname = ogr2osm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..152a421ac872
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: jerry73204 <jerry73204 at gmail dot com>
+pkgname=ogr2osm-git
+pkgver=r141.4f5318b
+pkgrel=1
+pkgdesc='A tool for converting ogr-readable files like shapefiles into .osm data'
+arch=('any')
+url='https://github.com/pnorman/ogr2osm'
+license=('MIT')
+depends=('python' 'python-gdal')
+makedepends=('git' 'python-setuptools')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(
+ 'ogr2osm::git+https://github.com/pnorman/ogr2osm.git'
+ 'setup.py'
+)
+sha256sums=('SKIP'
+ '18049525bdc1d0c99d2863ac1d88b149e7dc9d4f2c521ff2e523c04bdc5f3961')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ cp ${srcdir}/setup.py setup.py
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ python3 setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python3 setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+}
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000000..f8e2b7c06034
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,25 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+from setuptools import setup
+
+setup(
+ name='ogr2osm',
+ version='0.1',
+ author='pnorman',
+ author_email='penorman@mac.com',
+ description="pnorman's version of UVM's Rewrite of ogr2osm",
+ license='MIT',
+ url='https://github.com/pnorman/ogr2osm/',
+ install_requires=[
+ 'GDAL'
+ ],
+ py_modules=[
+ 'ogr2osm',
+ 'geom',
+ ],
+ entry_points={
+ 'console_scripts': [
+ 'ogr2osm=ogr2osm:main',
+ ]
+ }
+)