summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek J. Clark2023-02-01 20:33:32 -0800
committerDerek J. Clark2023-02-01 20:33:32 -0800
commitb2b508aded160d41d2f76e4a6ae321c7808e0616 (patch)
treede1177fb9e595c09f38a244f23d1726a55d926bd
downloadaur-b2b508aded160d41d2f76e4a6ae321c7808e0616.tar.gz
Initial commit. v0.0.1-alhpa1
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD60
2 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c16de3ef602
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = ogui-git
+ pkgdesc = Open source game launcher
+ pkgver = v0.0.1.r34.g22b9d02
+ pkgrel = 1
+ url = https://github.com/ShadowBlip/OpenGamepadUI
+ arch = x86_64
+ license = GPL
+ makedepends = godot4-bin
+ makedepends = scons
+ makedepends = pkgconf
+ makedepends = gcc
+ makedepends = libxcursor
+ makedepends = libxinerama
+ makedepends = libxi
+ makedepends = libxrandr
+ makedepends = mesa
+ makedepends = glu
+ makedepends = libglvnd
+ makedepends = alsa-lib
+ makedepends = make
+ makedepends = unzip
+ makedepends = wget
+ makedepends = git
+ depends = glibc
+ depends = gcc-libs
+ depends = libx11
+ depends = libxres
+ depends = libxcb
+ depends = libxext
+ depends = libxau
+ depends = libxdmcp
+ depends = gamescope
+ depends = ryzenadj-git
+ provides = ogui
+ source = OpenGamepadUI::git+https://github.com/ShadowBlip/OpenGamepadUI.git#tag=22b9d028a2f27586f5b4e256c8c578b5bb149a05
+ sha256sums = SKIP
+
+pkgname = ogui-git
+ options = !strip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44f4ab519d81
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Derek J. Clark <derekjohn.clark@gmail.com>
+pkgname=ogui-git
+_pkgbase=OpenGamepadUI
+pkgver=v0.0.1.r34.g22b9d02
+pkgrel=1
+pkgdesc="Open source game launcher"
+arch=('x86_64')
+url="https://github.com/ShadowBlip/OpenGamepadUI"
+license=('GPL')
+groups=()
+depends=('glibc' 'gcc-libs' 'libx11' 'libxres' 'libxcb' 'libxext' 'libxau'
+ 'libxdmcp' 'gamescope' 'ryzenadj-git'
+ )
+optdepends=()
+makedepends=('godot4-bin' 'scons' 'pkgconf' 'gcc' 'libxcursor' 'libxinerama'
+ 'libxi' 'libxrandr' 'mesa' 'glu' 'libglvnd' 'alsa-lib' 'make'
+ 'unzip' 'wget' 'git'
+ )
+provides=('ogui')
+_tag=22b9d028a2f27586f5b4e256c8c578b5bb149a05
+source=("${_pkgbase}::git+https://github.com/ShadowBlip/${_pkgbase}.git#tag=${_tag}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgbase}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/${_pkgbase}"
+}
+
+build() {
+ cd "$srcdir/${_pkgbase}"
+ make addons import build
+}
+
+package() {
+ options=('!strip')
+ cd "$srcdir/${_pkgbase}"
+
+ mkdir -p ${pkgdir}/etc/handypt
+ install -Dm755 rootfs/etc/handypt/powertools ${pkgdir}/etc/handypt
+
+ mkdir -p ${pkgdir}/usr/bin
+ echo -e '#!/bin/sh\nexec /usr/share/opengamepadui/opengamepad-ui.x86_64 "$@"' > ${pkgdir}/usr/bin/opengamepadui
+
+ chmod +x ${pkgdir}/usr/bin/opengamepadui
+
+ mkdir -p ${pkgdir}/usr/lib/systemd/user
+ install -Dm644 rootfs/usr/lib/systemd/user/ogui-qam.service ${pkgdir}/usr/lib/systemd/user
+
+ mkdir -p ${pkgdir}/usr/share/opengamepadui
+ install -Dm644 build/libevdev.linux.template_debug.x86_64.so ${pkgdir}/usr/share/opengamepadui/libevdev.linux.template_debug.x86_64.so
+ install -Dm644 build/libxlib.linux.template_debug.x86_64.so ${pkgdir}/usr/share/opengamepadui/libxlib.linux.template_debug.x86_64.so
+ install -Dm755 build/opengamepad-ui.x86_64 ${pkgdir}/usr/share/opengamepadui/opengamepad-ui.x86_64
+
+ mkdir -p ${pkgdir}/usr/share/polkit-1/actions
+ install -Dm644 rootfs/usr/share/polkit-1/actions/org.shadowblip.powertools.policy ${pkgdir}/usr/share/polkit-1/actions
+}