summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan McCurry2017-01-02 23:51:32 -0500
committerDan McCurry2017-01-02 23:51:32 -0500
commit92711754a7d6a40a19d40826639ce4ac169e1ac8 (patch)
tree63dfa8046c5584f21a21690ff33c26b04705cf18
downloadaur-92711754a7d6a40a19d40826639ce4ac169e1ac8.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6907af2f4179
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = oh-brother-git
+ pkgdesc = A simple cross-platform utility writeen in Python which can update Brother printer firmwares.
+ pkgver = r22.6c73096
+ pkgrel = 1
+ url = https://github.com/CauldronDevelopmentLLC/oh-brother
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = python2-pyasn1
+ depends = python2-pysnmp
+ provides = oh-brother
+ conflicts = oh-brother
+ source = oh-brother::git+https://github.com/CauldronDevelopmentLLC/oh-brother.git
+ md5sums = SKIP
+
+pkgname = oh-brother-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33cc02e8769e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Dan McCurry <dan.mccurry at linux dot com>
+pkgname=oh-brother-git
+pkgver=r22.6c73096
+pkgrel=1
+pkgdesc="A simple cross-platform utility writeen in Python which can update Brother printer firmwares."
+arch=('any')
+url="https://github.com/CauldronDevelopmentLLC/oh-brother"
+license=('GPL2')
+makedepends=('git')
+depends=('python2-pyasn1' 'python2-pysnmp')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}::git+https://github.com/CauldronDevelopmentLLC/oh-brother.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ sed -i '1 s/python/python2/' oh-brother.py
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm755 "oh-brother.py" "${pkgdir}/usr/bin/oh-brother.py"
+}