summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Kahrmann2020-03-29 17:01:48 +0200
committerOliver Kahrmann2020-03-29 17:01:48 +0200
commite5be69b215053c296425e2d248e93ab007681e97 (patch)
tree7b849e282cf65b5094816ce2c7dd37655491fddc
parent86d914ceb6664a0cecb0e3c7cb2c4485b4ce9a3d (diff)
downloadaur-e5be69b215053c296425e2d248e93ab007681e97.tar.gz
Update to python3 dependencies
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a9639671dd56..e52102dfefd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,15 @@
# Maintainer: Dan McCurry <dan.mccurry at linux dot com>
+# Contributor: Oliver Kahrmann <oliver.kahrmann@gmail.com>
+
pkgname=oh-brother-git
-pkgver=r22.6c73096
-pkgrel=1
+pkgver=r39.e667fe7
+pkgrel=2
pkgdesc="A simple cross-platform utility written in Python which can update Brother printer firmwares."
arch=('any')
url="https://github.com/CauldronDevelopmentLLC/oh-brother"
license=('GPL2')
makedepends=('git')
-depends=('python2-pyasn1' 'python2-pysnmp')
+depends=('python-pyasn1' 'python-pysnmp' 'python-future')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("${pkgname%-git}::git+https://github.com/CauldronDevelopmentLLC/oh-brother.git")
@@ -20,11 +22,11 @@ pkgver() {
prepare() {
cd "$srcdir/${pkgname%-git}"
- sed -i '1 s/python/python2/' oh-brother.py
+ sed -i '1 s/python/python3/' oh-brother.py
}
package() {
cd "$srcdir/${pkgname%-git}"
install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
- install -Dm755 "oh-brother.py" "${pkgdir}/usr/bin/oh-brother.py"
+ install -Dm755 "oh-brother.py" "${pkgdir}/usr/bin/oh-brother"
}