summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAditya Sirish2023-05-23 12:46:57 -0400
committerAditya Sirish2023-05-23 12:46:57 -0400
commit772da89ab62e413e2e285430e3bfb1f4dc3676b2 (patch)
tree8455754232f5b386eeadb31f32a312ed4823e17d
parent81a395edb2b459d8409d4e248d2f33c8e5427718 (diff)
downloadaur-772da89ab62e413e2e285430e3bfb1f4dc3676b2.tar.gz
Update oh my bash with new patch
Signed-off-by: Aditya Sirish <aditya@saky.in>
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore5
-rw-r--r--0001-bashrc.patch63
-rw-r--r--PKGBUILD7
4 files changed, 59 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b065ffc7ccaa..9beca3a7da7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oh-my-bash-git
pkgdesc = A delightful community-driven framework for managing your bash configuration, and an auto-update tool so that makes it easy to keep up with the latest updates from the community
- pkgver = r90.89e5054
+ pkgver = r461.dd7807f
pkgrel = 1
url = https://github.com/ohmybash/oh-my-bash
install = oh-my-bash-git.install
@@ -13,10 +13,9 @@ pkgbase = oh-my-bash-git
optdepends = wget
optdepends = python: for some plugin functionality
optdepends = git: most themes use git (highly recommended but still optional)
- source = oh-my-bash-git::git+git://github.com/ohmybash/oh-my-bash.git
+ source = oh-my-bash-git::git+https://github.com/ohmybash/oh-my-bash
source = 0001-bashrc.patch
sha256sums = SKIP
sha256sums = SKIP
pkgname = oh-my-bash-git
-
diff --git a/.gitignore b/.gitignore
index 1fd827eeaf0c..444199e27a94 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,4 +4,7 @@ setup-git-v1.sh
setup-git-v*.sh
*.gz
*.zst
-*.xz \ No newline at end of file
+*.xz
+oh-my-bash-git/
+pkg/
+src/ \ No newline at end of file
diff --git a/0001-bashrc.patch b/0001-bashrc.patch
index d92b7b023c22..84ea11090141 100644
--- a/0001-bashrc.patch
+++ b/0001-bashrc.patch
@@ -1,14 +1,16 @@
--- a/bashrc
+++ b/bashrc
-@@ -1,5 +1,5 @@
+@@ -5,7 +5,7 @@ case $- in
+ esac
+
# Path to your oh-my-bash installation.
--export OSH=$HOME/.oh-my-bash
-+OSH=/usr/share/oh-my-bash
+-export OSH=~/.oh-my-bash
++export OSH=/usr/share/oh-my-bash
# Set name of the theme to load. Optionally, if you set this to "random"
# it'll load a random theme each time that oh-my-bash is loaded.
-@@ -13,7 +13,7 @@
- # HYPHEN_INSENSITIVE="true"
+@@ -19,7 +19,7 @@ OSH_THEME="font"
+ # OMB_HYPHEN_SENSITIVE="false"
# Uncomment the following line to disable bi-weekly auto-update checks.
-# DISABLE_AUTO_UPDATE="true"
@@ -16,23 +18,56 @@
# Uncomment the following line to change how often to auto-update (in days).
# export UPDATE_OSH_DAYS=13
-@@ -70,7 +70,7 @@
- bashmarks
- )
+@@ -72,11 +72,11 @@ OMB_USE_SUDO=true
+ # Custom completions may be added to ~/.oh-my-bash/custom/completions/
+ # Example format: completions=(ssh git bundler gem pip pip3)
+ # Add wisely, as too many completions slow down shell startup.
+-completions=(
+- git
+- composer
+- ssh
+-)
++# completions=(
++# git
++# composer
++# ssh
++# )
--source $OSH/oh-my-bash.sh
-+
+ # Which aliases would you like to load? (aliases can be found in ~/.oh-my-bash/aliases/*)
+ # Custom aliases may be added to ~/.oh-my-bash/custom/aliases/
+@@ -90,10 +90,10 @@ aliases=(
+ # Custom plugins may be added to ~/.oh-my-bash/custom/plugins/
+ # Example format: plugins=(rails git textmate ruby lighthouse)
+ # Add wisely, as too many plugins slow down shell startup.
+-plugins=(
+- git
+- bashmarks
+-)
++# plugins=(
++# git
++# bashmarks
++# )
+
+ # Which plugins would you like to conditionally load? (plugins can be found in ~/.oh-my-bash/plugins/*)
+ # Custom plugins may be added to ~/.oh-my-bash/custom/plugins/
+@@ -102,8 +102,6 @@ plugins=(
+ # plugins+=(tmux-autoattach)
+ # fi
+-source "$OSH"/oh-my-bash.sh
+-
# User configuration
# export MANPATH="/usr/local/man:$MANPATH"
-@@ -99,3 +99,9 @@
+
+@@ -131,3 +129,11 @@ source "$OSH"/oh-my-bash.sh
# Example aliases
# alias bashconfig="mate ~/.bashrc"
# alias ohmybash="mate ~/.oh-my-bash"
+
+BASH_CACHE_DIR=$HOME/.cache/oh-my-bash
+if [[ ! -d $BASH_CACHE_DIR ]]; then
-+ mkdir $BASH_CACHE_DIR
++ mkdir $BASH_CACHE_DIR
+fi
-+source $OSH/oh-my-bash.sh
-
++
++source "$OSH"/oh-my-bash.sh
++
diff --git a/PKGBUILD b/PKGBUILD
index 85fc1daca923..0959fef98e6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Marco Obaid <marco.obaid@gmail.com>
+# Maintainer: Aditya Sirish <aditya at saky dot in>
+# Contributor: Marco Obaid <marco.obaid@gmail.com>
pkgname=oh-my-bash-git
-pkgver=r90.89e5054
+pkgver=r461.dd7807f
pkgrel=1
pkgdesc="A delightful community-driven framework for managing your bash configuration, and an auto-update tool so that makes it easy to keep up with the latest updates from the community"
arch=('x86_64')
@@ -17,7 +18,7 @@ optdepends=('ruby: for some plugin functionality'
install=${pkgname}.install
-source=("${pkgname}::git+git://github.com/ohmybash/oh-my-bash.git"
+source=("${pkgname}::git+${url}"
'0001-bashrc.patch')
sha256sums=('SKIP'