summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Obaid2020-01-14 21:26:54 -0600
committerMarco Obaid2020-01-14 21:26:54 -0600
commite9fae5fb77ca7b569ffcb9d84fa516aa4a794b88 (patch)
tree051b4dc28681bd3a40b3275d06aa162a8cc1832f
downloadaur-e9fae5fb77ca7b569ffcb9d84fa516aa4a794b88.tar.gz
Initial Commit - Release 64
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore7
-rw-r--r--0001-bashrc.patch38
-rw-r--r--PKGBUILD44
-rw-r--r--oh-my-bash-git.install14
5 files changed, 125 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e6778f58333
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = oh-my-bash-git
+ pkgdesc = A delightful community-driven framework for managing your bash configuration, and an auto-update tool so that makes it easy to keep up with the latest updates from the community
+ pkgver = r64.ec19214
+ pkgrel = 1
+ url = https://github.com/ohmybash/oh-my-bash
+ install = oh-my-bash-git.install
+ arch = x86_64
+ license = WTFPL
+ makedepends = git
+ depends = bash
+ optdepends = ruby: for some plugin functionality
+ optdepends = curl
+ optdepends = wget
+ optdepends = python: for some plugin functionality
+ optdepends = git: most themes use git (highly recommended but still optional)
+ source = oh-my-bash-git::git+git://github.com/ohmybash/oh-my-bash.git
+ source = 0001-bashrc.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = oh-my-bash-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1fd827eeaf0c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+git-v2.sh
+git-v*.sh
+setup-git-v1.sh
+setup-git-v*.sh
+*.gz
+*.zst
+*.xz \ No newline at end of file
diff --git a/0001-bashrc.patch b/0001-bashrc.patch
new file mode 100644
index 000000000000..d92b7b023c22
--- /dev/null
+++ b/0001-bashrc.patch
@@ -0,0 +1,38 @@
+--- a/bashrc
++++ b/bashrc
+@@ -1,5 +1,5 @@
+ # Path to your oh-my-bash installation.
+-export OSH=$HOME/.oh-my-bash
++OSH=/usr/share/oh-my-bash
+
+ # Set name of the theme to load. Optionally, if you set this to "random"
+ # it'll load a random theme each time that oh-my-bash is loaded.
+@@ -13,7 +13,7 @@
+ # HYPHEN_INSENSITIVE="true"
+
+ # Uncomment the following line to disable bi-weekly auto-update checks.
+-# DISABLE_AUTO_UPDATE="true"
++DISABLE_AUTO_UPDATE="true"
+
+ # Uncomment the following line to change how often to auto-update (in days).
+ # export UPDATE_OSH_DAYS=13
+@@ -70,7 +70,7 @@
+ bashmarks
+ )
+
+-source $OSH/oh-my-bash.sh
++
+
+ # User configuration
+ # export MANPATH="/usr/local/man:$MANPATH"
+@@ -99,3 +99,9 @@
+ # Example aliases
+ # alias bashconfig="mate ~/.bashrc"
+ # alias ohmybash="mate ~/.oh-my-bash"
++
++BASH_CACHE_DIR=$HOME/.cache/oh-my-bash
++if [[ ! -d $BASH_CACHE_DIR ]]; then
++ mkdir $BASH_CACHE_DIR
++fi
++source $OSH/oh-my-bash.sh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5620496b0df3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Marco Obaid <marco.obaid@gmail.com>
+
+pkgname=oh-my-bash-git
+pkgver=r64.ec19214
+pkgrel=1
+pkgdesc="A delightful community-driven framework for managing your bash configuration, and an auto-update tool so that makes it easy to keep up with the latest updates from the community"
+arch=('x86_64')
+url='https://github.com/ohmybash/oh-my-bash'
+license=('WTFPL')
+depends=('bash')
+makedepends=('git')
+optdepends=('ruby: for some plugin functionality'
+ 'curl'
+ 'wget'
+ 'python: for some plugin functionality'
+ 'git: most themes use git (highly recommended but still optional)')
+
+install=${pkgname}.install
+
+source=("${pkgname}::git+git://github.com/ohmybash/oh-my-bash.git"
+ '0001-bashrc.patch')
+
+sha256sums=('SKIP'
+ 'SKIP')
+
+
+pkgver() {
+ cd ${pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ cp "templates/bashrc.osh-template" "bashrc"
+ patch -p1 < "${srcdir}/0001-bashrc.patch"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ mkdir -p "${pkgdir}/usr/share/oh-my-bash"
+ install -D -m644 "LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cp -r * "${pkgdir}/usr/share/oh-my-bash/"
+}
diff --git a/oh-my-bash-git.install b/oh-my-bash-git.install
new file mode 100644
index 000000000000..425a5ed82256
--- /dev/null
+++ b/oh-my-bash-git.install
@@ -0,0 +1,14 @@
+post_install () {
+ echo "================================================================"
+ echo " *** IMPORTANT ***"
+ echo "This package does not modify any files in your home folder.";
+ echo "Backup your current .bashrc, then copy the new one by executing:";
+ echo "'cp /usr/share/oh-my-bash/bashrc ~/.bashrc'";
+ echo "then source it.";
+ echo "================================================================"
+
+}
+
+post_remove () {
+ echo "Please check ~/.bashrc to avoid errors."
+}