summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven-Hendrik Haase2020-04-27 14:01:04 +0200
committerSven-Hendrik Haase2020-04-27 14:01:04 +0200
commit6d5f1dc6e9d92d62a2b2b67e5db215638d2b73c6 (patch)
tree6f29da82f2f525fc157a512598572deb2db63c0e
downloadaur-6d5f1dc6e9d92d62a2b2b67e5db215638d2b73c6.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..30e8dfaa4334
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = oha
+ pkgdesc = Ohayou(おはよう), HTTP load generator, inspired by rakyll/hey with tui animation
+ pkgver = 0.2.3
+ pkgrel = 1
+ url = https://github.com/hatoo/oha
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ source = oha-0.2.3.tar.gz::https://github.com/hatoo/oha/archive/v0.2.3.tar.gz
+ sha512sums = de0b9157dee042bd5ceb102c409a6b240517a3966455dd7794f988fd00d5ab9f03542516fb3773f11c2ad491e202e195247b32886b19d589a7675a03f4a8fce2
+
+pkgname = oha
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f9a5b9c3625
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Sven-Hendrik Haase <svenstaro@gmail.com>
+
+pkgname=oha
+pkgver=0.2.3
+pkgrel=1
+pkgdesc="Ohayou(おはよう), HTTP load generator, inspired by rakyll/hey with tui animation"
+arch=('x86_64')
+url="https://github.com/hatoo/oha"
+license=(MIT)
+makedepends=(cargo)
+source=($pkgname-$pkgver.tar.gz::https://github.com/hatoo/oha/archive/v${pkgver}.tar.gz)
+sha512sums=('de0b9157dee042bd5ceb102c409a6b240517a3966455dd7794f988fd00d5ab9f03542516fb3773f11c2ad491e202e195247b32886b19d589a7675a03f4a8fce2')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ cargo build --release --locked
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -Dm755 target/release/oha "$pkgdir"/usr/bin/oha
+}
+
+# vim:set ts=2 sw=2 et: