summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven-Hendrik Haase2020-05-17 09:50:21 +0200
committerSven-Hendrik Haase2020-05-17 09:50:21 +0200
commit83eef4ce19503dcb28b84f3ce61bf6713f6b9999 (patch)
tree5a4fcb57987e3cf92f157ebcc9ddacb4ff3114e2
parentb352404e0b4b8fcbb28ca6909b786689db626d0e (diff)
downloadaur-83eef4ce19503dcb28b84f3ce61bf6713f6b9999.tar.gz
0.3.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e1ce2b44394..6f4e7a043f6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = oha
pkgdesc = Ohayou(おはよう), HTTP load generator, inspired by rakyll/hey with tui animation
- pkgver = 0.2.5
+ pkgver = 0.3.1
pkgrel = 1
url = https://github.com/hatoo/oha
arch = x86_64
license = MIT
makedepends = cargo
- source = oha-0.2.5.tar.gz::https://github.com/hatoo/oha/archive/v0.2.5.tar.gz
- sha512sums = b581df1b41a68f9e7011ef501bd2809e813228280e87b4f172fef4b017074c8a70dd7c011e9a841a2b9a7ae0bf8927f0d31b8cf92e52f1cf2a15ee17b024917c
+ depends = openssl
+ source = oha-0.3.1.tar.gz::https://github.com/hatoo/oha/archive/v0.3.1.tar.gz
+ sha512sums = 712e67771b93cecf06cf097e6c1aad5d82618aa88d899ae8d3645de6557e7352259e7f0aa6913b75ac507313a8e77198dc3916fa4deb2b5e93aa1e58724b3599
pkgname = oha
diff --git a/PKGBUILD b/PKGBUILD
index 367bc05bca0c..05756200e628 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
# Maintainer: Sven-Hendrik Haase <svenstaro@gmail.com>
pkgname=oha
-pkgver=0.2.5
+pkgver=0.3.1
pkgrel=1
pkgdesc="Ohayou(おはよう), HTTP load generator, inspired by rakyll/hey with tui animation"
arch=('x86_64')
url="https://github.com/hatoo/oha"
license=(MIT)
+depends=(openssl)
makedepends=(cargo)
source=($pkgname-$pkgver.tar.gz::https://github.com/hatoo/oha/archive/v${pkgver}.tar.gz)
-sha512sums=('b581df1b41a68f9e7011ef501bd2809e813228280e87b4f172fef4b017074c8a70dd7c011e9a841a2b9a7ae0bf8927f0d31b8cf92e52f1cf2a15ee17b024917c')
+sha512sums=('712e67771b93cecf06cf097e6c1aad5d82618aa88d899ae8d3645de6557e7352259e7f0aa6913b75ac507313a8e77198dc3916fa4deb2b5e93aa1e58724b3599')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -17,6 +18,12 @@ build() {
cargo build --release --locked
}
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ cargo test --release --locked
+}
+
package() {
cd "$srcdir/$pkgname-$pkgver"