summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Lawrence2015-07-04 14:17:54 -0400
committerScott Lawrence2015-07-04 14:17:54 -0400
commit0165bf532d73716a45c8aeff49955796759f4dac (patch)
tree4c168e5eb0ccc992073a0a8dea0f4f8c26f964e0
downloadaur-0165bf532d73716a45c8aeff49955796759f4dac.tar.gz
Initial copy from aur
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c85316690928
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = ohcount
+ pkgdesc = A source-lines of code counter.
+ pkgver = 3.0.0
+ pkgrel = 3
+ url = http://labs.ohloh.net/ohcount
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = ragel>=6.3
+ makedepends = bash
+ makedepends = gcc>=4.1.2
+ makedepends = swig
+ makedepends = ruby
+ makedepends = rake
+ makedepends = gperf
+ depends = pcre
+ source = https://github.com/blackducksw/ohcount/tarball/3.0.0
+ md5sums = 85e46186adfbd0c9db1d9a9c9a7efd39
+
+pkgname = ohcount
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16c9c4ea4899
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Scott Lawrence <bytbox@gmail.com>
+# Contributor: Daniel Fiser <danfis (at) danfis (dot) cz>
+pkgname=ohcount
+pkgver=3.0.0
+pkgrel=3
+pkgdesc="A source-lines of code counter."
+arch=(i686 x86_64)
+url="http://labs.ohloh.net/ohcount"
+license=('GPL')
+depends=(pcre)
+makedepends=('ragel>=6.3' bash 'gcc>=4.1.2' swig ruby rake gperf)
+provides=()
+conflicts=()
+replaces=()
+backup=()
+install=
+source=("https://github.com/blackducksw/ohcount/tarball/$pkgver")
+md5sums=('85e46186adfbd0c9db1d9a9c9a7efd39')
+dfname='blackducksw-ohcount-d7d6124'
+
+build() {
+ cd $srcdir/$dfname
+
+ ./build ohcount
+
+ mkdir -p $startdir/pkg/usr/bin
+
+ cp bin/ohcount $startdir/pkg/usr/bin/
+}