summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenneth Endfinger2020-01-13 02:20:25 -0500
committerKenneth Endfinger2020-01-13 02:20:25 -0500
commit80713bea1cce91b8b4a289aa5e2b81ea7235dbd4 (patch)
treec2653b5213261b34ad4ab7ab22b28a0a26489c77
parentb998e24c924a9b2904dbaed04bcc36c74344c2e2 (diff)
downloadaur-80713bea1cce91b8b4a289aa5e2b81ea7235dbd4.tar.gz
v4.0.0
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD23
3 files changed, 21 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a546f6e02f6..a63e28c997d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = ohcount
pkgdesc = source-lines of code counter
- pkgver = 3.1.0
+ pkgver = 4.0.0
pkgrel = 1
url = http://labs.ohloh.net/ohcount
- arch = i686
- arch = x86_64
+ arch = any
license = GPL
makedepends = ragel>=6.3
makedepends = swig
makedepends = ruby
- makedepends = rake
+ makedepends = ruby-rake
makedepends = gperf
depends = pcre
- source = ohcount-3.1.0.tar.gz::https://github.com/blackducksoftware/ohcount/archive/v3.1.0.tar.gz
- md5sums = a6c62adaea3f8b47a731a68d61660f60
+ source = ohcount-4.0.0.tar.gz::https://github.com/blackducksoftware/ohcount/archive/4.0.0.tar.gz
+ sha256sums = d71f69fd025f5bae58040988108f0d8d84f7204edda1247013cae555bfdae1b9
pkgname = ohcount
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0015a5804f69
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/src
+/pkg
+*.xz
+*.tar.*
+*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
index db9d27ac84cc..8e20af22977f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,27 @@
-# Contributor: Scott Lawrence <bytbox@gmail.com>
-# Contributor: Daniel Fiser <danfis (at) danfis (dot) cz>
+# Maintainer: Kenneth Endfinger <kaendfinger@gmail.com>
pkgname=ohcount
-pkgver=3.1.0
+pkgver=4.0.0
pkgrel=1
pkgdesc="source-lines of code counter"
-arch=(i686 x86_64)
+arch=('any')
url="http://labs.ohloh.net/ohcount"
license=('GPL')
-depends=(pcre)
-makedepends=('ragel>=6.3' 'swig' 'ruby' 'rake' 'gperf')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/blackducksoftware/ohcount/archive/v${pkgver}.tar.gz")
-md5sums=('a6c62adaea3f8b47a731a68d61660f60')
+depends=('pcre')
+makedepends=('ragel>=6.3' 'swig' 'ruby' 'ruby-rake' 'gperf')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/blackducksoftware/ohcount/archive/${pkgver}.tar.gz")
+sha256sums=('d71f69fd025f5bae58040988108f0d8d84f7204edda1247013cae555bfdae1b9')
build() {
- cd "$pkgname"
+ cd "${pkgname}-${pkgver}"
./build ohcount
}
package() {
- cd "$pkgname"
+ cd "${pkgname}-${pkgver}"
- mkdir -p "$pkgdir/usr/bin"
- cp bin/ohcount "$pkgdir/usr/bin/"
+ mkdir -p "${pkgdir}/usr/bin"
+ cp bin/ohcount "${pkgdir}/usr/bin/"
}