summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2018-06-04 03:10:55 +0200
committerNarrat2018-06-04 03:10:55 +0200
commitb998e24c924a9b2904dbaed04bcc36c74344c2e2 (patch)
treeffdeb196e08755b62b01418bb9b36956001524b4
parent0165bf532d73716a45c8aeff49955796759f4dac (diff)
downloadaur-b998e24c924a9b2904dbaed04bcc36c74344c2e2.tar.gz
ohcount: update to 3.1.0
And fix the PKGBUILD, because it was missing a package() function...
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD31
2 files changed, 20 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c85316690928..1a546f6e02f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = ohcount
- pkgdesc = A source-lines of code counter.
- pkgver = 3.0.0
- pkgrel = 3
+ pkgdesc = source-lines of code counter
+ pkgver = 3.1.0
+ pkgrel = 1
url = http://labs.ohloh.net/ohcount
arch = i686
arch = x86_64
license = GPL
makedepends = ragel>=6.3
- makedepends = bash
- makedepends = gcc>=4.1.2
makedepends = swig
makedepends = ruby
makedepends = rake
makedepends = gperf
depends = pcre
- source = https://github.com/blackducksw/ohcount/tarball/3.0.0
- md5sums = 85e46186adfbd0c9db1d9a9c9a7efd39
+ source = ohcount-3.1.0.tar.gz::https://github.com/blackducksoftware/ohcount/archive/v3.1.0.tar.gz
+ md5sums = a6c62adaea3f8b47a731a68d61660f60
pkgname = ohcount
diff --git a/PKGBUILD b/PKGBUILD
index 16c9c4ea4899..db9d27ac84cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,28 @@
-# Maintainer: Scott Lawrence <bytbox@gmail.com>
+# Contributor: Scott Lawrence <bytbox@gmail.com>
# Contributor: Daniel Fiser <danfis (at) danfis (dot) cz>
+
pkgname=ohcount
-pkgver=3.0.0
-pkgrel=3
-pkgdesc="A source-lines of code counter."
+pkgver=3.1.0
+pkgrel=1
+pkgdesc="source-lines of code counter"
arch=(i686 x86_64)
url="http://labs.ohloh.net/ohcount"
license=('GPL')
depends=(pcre)
-makedepends=('ragel>=6.3' bash 'gcc>=4.1.2' swig ruby rake gperf)
-provides=()
-conflicts=()
-replaces=()
-backup=()
-install=
-source=("https://github.com/blackducksw/ohcount/tarball/$pkgver")
-md5sums=('85e46186adfbd0c9db1d9a9c9a7efd39')
-dfname='blackducksw-ohcount-d7d6124'
+makedepends=('ragel>=6.3' 'swig' 'ruby' 'rake' 'gperf')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/blackducksoftware/ohcount/archive/v${pkgver}.tar.gz")
+md5sums=('a6c62adaea3f8b47a731a68d61660f60')
+
build() {
- cd $srcdir/$dfname
+ cd "$pkgname"
./build ohcount
+}
- mkdir -p $startdir/pkg/usr/bin
+package() {
+ cd "$pkgname"
- cp bin/ohcount $startdir/pkg/usr/bin/
+ mkdir -p "$pkgdir/usr/bin"
+ cp bin/ohcount "$pkgdir/usr/bin/"
}