summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspider-mario2015-06-27 16:41:35 +0200
committerspider-mario2015-06-27 16:41:35 +0200
commitf5d5ad82206fbbba8077085d1b7961c20e5c24cc (patch)
tree6ab2a5972d89f77befb7930c1815743af0e48ceb
downloadaur-f5d5ad82206fbbba8077085d1b7961c20e5c24cc.tar.gz
initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD34
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dfff4cc5d9aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ohcount-git
+ pkgdesc = Ohcount is a source code line counter.
+ pkgver = 2.0.1.312.g4fb66a8
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/blackducksw/ohcount
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = bash
+ makedepends = ruby
+ makedepends = ragel
+ makedepends = gperf
+ depends = pcre
+ provides = ohcount
+ conflicts = ohcount
+ source = git+https://github.com/blackducksw/ohcount.git
+ sha512sums = SKIP
+
+pkgname = ohcount-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56544a4b3616
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: spider-mario <spidermario@free.fr>
+# Contributor: Serge Ziryukin <ftrvxmtrx@gmail.com>
+pkgname=ohcount-git
+pkgver=2.0.1.312.g4fb66a8
+epoch=1
+pkgrel=1
+pkgdesc="Ohcount is a source code line counter."
+arch=('i686' 'x86_64')
+url="https://github.com/blackducksw/ohcount"
+license=('GPL')
+depends=('pcre')
+makedepends=('git' 'bash' 'ruby' 'ragel' 'gperf')
+provides=('ohcount')
+conflicts=('ohcount')
+install=
+source=('git+https://github.com/blackducksw/ohcount.git')
+sha512sums=(SKIP)
+
+pkgver() {
+ cd ohcount
+ git describe | tr - .
+}
+
+build() {
+ cd ohcount
+ ./build ohcount
+}
+
+package() {
+ cd ohcount
+
+ install --directory "$pkgdir/usr/bin"
+ install bin/ohcount "$pkgdir/usr/bin/"
+}