summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn ShaggyTwoDope Jenkins2015-06-23 01:36:27 -0700
committerJohn ShaggyTwoDope Jenkins2015-06-23 01:36:27 -0700
commit4d63c270fc22d3895ca1049c07f25e3af9f08e32 (patch)
treecd8cd62081818bb12329beb1528c3735704a3675
downloadaur-4d63c270fc22d3895ca1049c07f25e3af9f08e32.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
-rw-r--r--ohsnap.install20
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dfeaad3fc40a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ohsnap
+ pkgdesc = Monospaced font based on Artwiz Snap.
+ pkgver = 1.8.0
+ pkgrel = 1
+ url = http://sourceforge.net/projects/osnapfont
+ install = ohsnap.install
+ arch = any
+ license = GPLv2
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ source = http://sourceforge.net/projects/osnapfont/files/ohsnap-1.8.0.tar.gz
+ md5sums = aeb3d8e1f9634900036f886a14b3b03a
+
+pkgname = ohsnap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4cbeb18e8c83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: John Jenkins twodopeshaggy@gmail.com
+# Contributor: stlarch stlarchie@gmail.com
+
+pkgname=ohsnap
+pkgver=1.8.0
+pkgrel=1
+pkgdesc="Monospaced font based on Artwiz Snap."
+arch=('any')
+url="http://sourceforge.net/projects/osnapfont"
+license=('GPLv2')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+install=ohsnap.install
+source=("http://sourceforge.net/projects/osnapfont/files/$pkgname-$pkgver.tar.gz")
+
+package () {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -d "$pkgdir/usr/share/fonts/local"
+ install -d "$pkgdir/usr/share/kbd/consolefonts"
+ install -d "$pkgdir/usr/share/doc/$pkgname"
+
+ install -m644 *.pcf "$pkgdir/usr/share/fonts/local"
+ install -m644 *.psfu "$pkgdir/usr/share/kbd/consolefonts"
+ install -m644 README.ohsnap "$pkgdir/usr/share/doc/$pkgname"
+}
+md5sums=('aeb3d8e1f9634900036f886a14b3b03a')
diff --git a/ohsnap.install b/ohsnap.install
new file mode 100644
index 000000000000..365fd902c279
--- /dev/null
+++ b/ohsnap.install
@@ -0,0 +1,20 @@
+# arg 1: the new package version
+post_install() {
+ echo "Updating font cache... "
+ fc-cache -fs >/dev/null 2>&1
+ mkfontscale /usr/share/fonts/local
+ mkfontdir /usr/share/fonts/local
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install $1
+}
+
+# arg 1: the old package version
+post_remove() {
+ fc-cache -fs >/dev/null 2>&1
+ mkfontscale /usr/share/fonts/local
+ mkfontdir /usr/share/fonts/local
+}