summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllenyou11262019-07-21 10:57:51 +0800
committerAllenyou11262019-07-21 10:57:51 +0800
commita162cbf0e77d284aa72d091a93e181cdc97a8a1f (patch)
tree39799053217ae09956dec8fcc0e7a20f63932ea6
downloadaur-a162cbf0e77d284aa72d091a93e181cdc97a8a1f.tar.gz
Tools for OIERs by Allenyou -- version 1.0.1000r
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD45
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5338c04138c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = oi-tools-allenyou
+ pkgdesc = Tools for OIers by Allenyou.
+ pkgver = 1.0.1000r
+ pkgrel = 1
+ epoch = 0
+ url = https://www.allenyou.wang
+ arch = any
+ license = GPL3
+ source = https://aurlib.allenyou.wang/oi-tools-allenyou/oi-tools-allenyou-1.0.1000r.tar.gz
+ md5sums = e2660dbaa051985d27f0723095db23fd
+
+pkgname = oi-tools-allenyou
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d927d182dad4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Allenyou <cfan789123@126.com>
+pkgname=oi-tools-allenyou
+pkgver=1.0.1000r
+pkgrel=1
+epoch=0
+pkgdesc="Tools for OIers by Allenyou."
+arch=(any)
+url="https://www.allenyou.wang"
+license=('GPL3')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://aurlib.allenyou.wang/$pkgname/$pkgname-$pkgver.tar.gz")
+noextract=()
+md5sums=('e2660dbaa051985d27f0723095db23fd')
+validpgpkeys=()
+
+build() {
+ cd "$startdir"/src/"$pkgname-$pkgver"
+ # cd src/"$pkgname-$pkgver"
+ g++ ConsolePauser.cpp -o ConsolePauser
+ g++ pause.cpp -o pause
+}
+
+package() {
+ # cd "$pkgname-$pkgver"
+ # make DESTDIR="$pkgdir/" install
+ cd "$startdir"/src/"$pkgname-$pkgver"
+ install -D -m=775 ConsolePauser "${pkgdir}/usr/bin/ConsolePauser"
+ install -D -m=775 pause "${pkgdir}/usr/bin/pause"
+}