summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-05-25 21:35:04 +0200
committerbartus2019-05-25 21:35:04 +0200
commitfaad9201ca858cbddd9dd04994976453c184fc49 (patch)
treedbde5269cb9bd7101d25915c3a8cb0778fdd2f86
parentfa998032d2bca0acbf4cc6316b27b7b89d48e0c4 (diff)
downloadaur-faad9201ca858cbddd9dd04994976453c184fc49.tar.gz
Add Travis Ci build and deploy.
-rw-r--r--.travis.yml36
-rw-r--r--.travis_deploy.sh8
2 files changed, 44 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 000000000000..32c3b61d47a0
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,36 @@
+sudo: required
+
+branches:
+ only:
+ - master
+
+cache:
+ directories:
+ - src
+# - AUR-repo
+
+services:
+- docker
+
+arch:
+ repos:
+# - papyros=http://dash.papyros.io/repos/$repo/$arch
+# - bartus=https://media.githubusercontent.com/media/bartoszek/AUR-repo/master
+ packages:
+ # arch/aur packages
+# - python
+# - perl
+ script:
+ - "sudo pacman -Sy"
+ - "makepkg -s --noconfirm"
+
+script:
+- "curl -s https://raw.githubusercontent.com/mikkeloscar/arch-travis/master/arch-travis.sh | bash"
+- "ls $(pwd)"
+
+deploy:
+ provider: script
+ script: bash .travis_deploy.sh
+ on:
+ branch: master
+ skip_cleanup: true
diff --git a/.travis_deploy.sh b/.travis_deploy.sh
new file mode 100644
index 000000000000..ac569f54e1a4
--- /dev/null
+++ b/.travis_deploy.sh
@@ -0,0 +1,8 @@
+. PKGBUILD
+git clone https://$GITHUB_ACCESS_TOKEN@github.com/bartoszek/AUR-repo.git
+cd AUR-repo
+cp $TRAVIS_BUILD_DIR/$pkgname-$pkgver*.pkg.tar.xz $(pwd)
+git add $pkgname-$pkgver*.pkg.tar.xz
+git status
+git commit -a -m "$pkgname $pkgver" -m "build_log: $TRAVIS_BUILD_WEB_URL"
+git push