summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2018-02-13 17:30:15 +0000
committerHans-Nikolai Viessmann2018-02-13 17:30:15 +0000
commit8c2ad2ec200f22c2217502f3a681f4c5ff36dcf5 (patch)
tree46b1508544215642c23eb4d57d76bf889b7842a7
downloadaur-8c2ad2ec200f22c2217502f3a681f4c5ff36dcf5.tar.gz
initial commit version 0.4.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd90c7825d23
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = oilshell
+ pkgdesc = Oil is a new unix shell
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = http://www.oilshell.org/
+ arch = x86_64
+ license = APACHE
+ optdepends = readline: for interactive features
+ options = !strip
+ source = https://www.oilshell.org/download/oil-0.4.0.tar.xz
+ md5sums = 576fbf53bbb00a85ae42041a073df1eb
+
+pkgname = oilshell
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70d2731f2c72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
+pkgname=oilshell
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="Oil is a new unix shell"
+arch=('x86_64')
+url="http://www.oilshell.org/"
+optdepends=('readline: for interactive features')
+license=('APACHE')
+options=(!strip)
+source=("https://www.oilshell.org/download/oil-${pkgver}.tar.xz")
+md5sums=('576fbf53bbb00a85ae42041a073df1eb')
+
+build() {
+ cd "oil-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "oil-$pkgver"
+
+ # make install is faked...
+ install -Dm755 _bin/oil.ovm "$pkgdir/usr/bin/oil.ovm"
+ ln -s /usr/bin/oil.ovm "$pkgdir/usr/bin/osh"
+}