summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2020-02-23 13:06:10 +0100
committerHans-Nikolai Viessmann2020-02-23 13:06:10 +0100
commitfca9982bb91e5ca4a2d17dbd0c4140d16de17402 (patch)
tree8cb33884b43f4346760c11956c6639e330e71ee4
parent48c320846468200208886727008b8b3a650962aa (diff)
downloadaur-fca9982bb91e5ca4a2d17dbd0c4140d16de17402.tar.gz
bump version to 0.7.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
2 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ab41aaabef3..f7a409e99af4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oilshell
pkgdesc = Oil, a new unix shell
- pkgver = 0.7.pre10
+ pkgver = 0.7.0
pkgrel = 1
url = http://www.oilshell.org/
install = oilshell.install
@@ -8,8 +8,8 @@ pkgbase = oilshell
license = APACHE
depends = readline
options = !strip
- source = https://www.oilshell.org/download/oil-0.7.pre10.tar.xz
- sha256sums = b2b2ed9411194aaa422481af3a20b2e4fd5a4dc28cd26306a82ea89b3356e13d
+ source = https://www.oilshell.org/download/oil-0.7.0.tar.xz
+ sha256sums = a37eb491ffee5766aa8719056d42d5d836309dc26e345ecd6a2a1d240cd18989
pkgname = oilshell
diff --git a/PKGBUILD b/PKGBUILD
index d248b4c484b8..83271a6cdb66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
pkgname=oilshell
-pkgver=0.7.pre10
+pkgver=0.7.0
pkgrel=1
pkgdesc='Oil, a new unix shell'
arch=('x86_64')
@@ -11,19 +11,24 @@ license=('APACHE')
options=(!strip)
install=oilshell.install
source=("https://www.oilshell.org/download/oil-${pkgver}.tar.xz")
-sha256sums=('b2b2ed9411194aaa422481af3a20b2e4fd5a4dc28cd26306a82ea89b3356e13d')
+sha256sums=('a37eb491ffee5766aa8719056d42d5d836309dc26e345ecd6a2a1d240cd18989')
build() {
- cd "oil-$pkgver"
- ./configure --prefix=/usr --with-readline
- make
+ cd "oil-$pkgver"
+ ./configure --prefix=/usr --with-readline
+ make
}
package() {
- cd "oil-$pkgver"
+ cd "oil-$pkgver"
- # the install script doesn't support DESTDIR
- install -Dm755 _bin/oil.ovm "$pkgdir/usr/bin/oil.ovm"
- ln -s /usr/bin/oil.ovm "$pkgdir/usr/bin/osh"
- ln -s /usr/bin/oil.ovm "$pkgdir/usr/bin/oshc"
+ # the install script doesn't support DESTDIR
+ install -Dm755 _bin/oil.ovm "$pkgdir/usr/bin/oil.ovm"
+ ln -s /usr/bin/oil.ovm "$pkgdir/usr/bin/osh"
+ ln -s /usr/bin/oil.ovm "$pkgdir/usr/bin/oshc"
+ ln -s /usr/bin/oil.ovm "$pkgdir/usr/bin/oil"
+
+ # install manpage
+ install -d "$pkgdir/usr/share/man/man1"
+ gunzip -fc doc/osh.1 > "$pkgdir/usr/share/man/man1/osh.1.gz"
}