summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeón Bohn2020-05-13 15:59:01 +0200
committerLeón Bohn2020-05-13 15:59:01 +0200
commitac2327cf2c7db6409ee7794afca8e1d654d7cd38 (patch)
treeae22412c1aec23a5d87a67cfd0ab773af29249d9
parente95dfa9e094845e4df8bb87e54c3979b05781a82 (diff)
downloadaur-ac2327cf2c7db6409ee7794afca8e1d654d7cd38.tar.gz
version bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ba1f795559a..b127ef06aa89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oink-git
pkgdesc = Oink is an implementation of modern parity game solvers written in C++.
- pkgver = r106.0beaf69
+ pkgver = r108.0464439
pkgrel = 1
url = https://github.com/trolando/oink
arch = i686
@@ -11,7 +11,7 @@ pkgbase = oink-git
makedepends = cmake
makedepends = boost
depends = boost-libs
- source = oink-git::git+https://github.com/trolando/oink#commit=0beaf69
+ source = oink-git::git+https://github.com/trolando/oink#commit=0464439
md5sums = SKIP
pkgname = oink-git
diff --git a/PKGBUILD b/PKGBUILD
index cbe9fd3ee717..5191d81c9700 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,22 @@
# Maintainer: León Bohn <leon.bohn@rwth-aachen.de>
pkgname=oink-git
-pkgver=r106.0beaf69
pkgrel=1
+pkgver=r108.0464439
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
pkgdesc="Oink is an implementation of modern parity game solvers written in C++."
arch=('i686' 'x86_64')
url="https://github.com/trolando/oink"
licecnse=('Apache 2.0')
-source=("oink-git::git+https://github.com/trolando/oink#commit=0beaf69")
+source=("oink-git::git+https://github.com/trolando/oink#commit=0464439")
makedepends=('git' 'gcc' 'make' 'cmake' 'boost')
depends=('boost-libs')
md5sums=('SKIP')
+
build() {
cd $pkgname
mkdir build && cd build