summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSammysHP2015-06-08 16:07:40 +0200
committerSammysHP2015-06-08 16:07:40 +0200
commit2f5fa66b7950cbf1c2bda98b810a2f298b702713 (patch)
treee503929a84afa24cbddc444083c99b3caa57e46a
downloadaur-2f5fa66b7950cbf1c2bda98b810a2f298b702713.tar.gz
Migrate from AUR3 to AUR4
Old history available at: https://github.com/SammysHP/oki-400-ps_PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD25
-rw-r--r--oki.install15
4 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fedfcb17ef4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = oki-400-ps
+ pkgdesc = CUPS drivers for OKI B4000, B400 and MB400 PS printers
+ pkgver = 1.4
+ pkgrel = 2
+ url = http://www.okidata.com/mkt/html/nf/Drivers.html
+ install = oki.install
+ arch = any
+ license = GPL
+ depends = cups
+ depends = ghostscript
+ depends = coreutils
+ source = ftp://ftp2.okidata.com/pub/drivers/linux/SFP/monochrome/desktop/OK400PS.tar
+ md5sums = 1a89c1c247745cfaef03cfe1abb45a85
+
+pkgname = oki-400-ps
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0a7995ff36de
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.tar.xz
+*.tar.gz
+*.tar
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7f979224ce6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Sven Karsten Greiner <sven@sammyshp.de>
+
+pkgname=oki-400-ps
+pkgver=1.4
+pkgrel=2
+pkgdesc="CUPS drivers for OKI B4000, B400 and MB400 PS printers"
+arch=('any')
+url="http://www.okidata.com/mkt/html/nf/Drivers.html"
+license=('GPL')
+depends=('cups' 'ghostscript' 'coreutils')
+source=("ftp://ftp2.okidata.com/pub/drivers/linux/SFP/monochrome/desktop/OK400PS.tar")
+install=oki.install
+md5sums=('1a89c1c247745cfaef03cfe1abb45a85')
+
+build() {
+ cd "$srcdir/OK400PS"
+ gunzip OK400PS.ppd.gz
+}
+
+package() {
+ cd "$srcdir/OK400PS"
+
+ install -D -m 755 okijobaccounting "${pkgdir}/usr/lib/cups/filter/okijobaccounting"
+ install -D -m 644 OK400PS.ppd "${pkgdir}/usr/share/cups/model/ok400ps.ppd"
+}
diff --git a/oki.install b/oki.install
new file mode 100644
index 000000000000..305d0c83590e
--- /dev/null
+++ b/oki.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -e "
+ If you experience any problems with printing
+ (like extra pages with PostScript code), try
+ blacklisting the module 'usblp'.
+
+ # echo \"blacklist usblp\" > /etc/modprobe.d/usblp.conf
+ "
+}
+
+post_upgrade() {
+ if [ "$(vercmp $2 1.4-2)" -lt 0 ]; then
+ post_install "$1"
+ fi
+}