summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-07-06 20:42:37 -0400
committerChris Severance2015-07-06 20:42:37 -0400
commitac2505c9ce821194ce817b09f1b57f7121f34b2d (patch)
treea4a42bd608c7f6576ab61aa4d8a9a7f56c69d116
downloadaur-ac2505c9ce821194ce817b09f1b57f7121f34b2d.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD48
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45246967440c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = oki-b411-b431
+ pkgdesc = cups driver for the Okidata B411 and B431
+ pkgver = 5.0.0
+ pkgrel = 1
+ url = http://www.okidata.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = cups
+ source = ftp://ftp2.okidata.com/pub/drivers/linux/SFP/monochrome/desktop/MB400PCLv5.tar
+ sha256sums = 3ab2df56a62e03d0c0f8dcbb09ea7cde757eac3eb9ab1772f5f3c421cbb6c73f
+
+pkgname = oki-b411-b431
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ce9762ef9b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Category: system
+
+# Recommended build & install command: makepkg -scCfi
+
+set -u
+pkgname='oki-b411-b431'
+_pkgnick='MB400PCL'
+pkgver='5.0.0'
+pkgrel=1
+pkgdesc='cups driver for the Okidata B411 and B431'
+url='http://www.okidata.com/'
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('cups')
+# install="${pkgname}.install"
+# An install is not necessary. Printers appear and disappear from cups
+# without a systemctl reload org.cups.cupsd.service or killall -HUP cupsd
+source=('ftp://ftp2.okidata.com/pub/drivers/linux/SFP/monochrome/desktop/MB400PCLv5.tar')
+sha256sums=('3ab2df56a62e03d0c0f8dcbb09ea7cde757eac3eb9ab1772f5f3c421cbb6c73f')
+
+prepare() {
+ set -u
+ #cd "${pkgname}-${pkgver}"
+ cd "${_pkgnick}"
+ # There's 101 ways to hack up this installer. I choose to
+ # fix it the way it should be for most package makers.
+ chmod 755 install.sh
+ sed -i -e 's:^\(_CUPS[A-Z]*="\):# \1:g' \
+ -e 's:PATH="\(/usr/\):PATH="${DESTDIR}\1:g' \
+ -e 's:^\(for i in \${_CUPS}\):if [ "${DESTDIR}" != "" ]; then\n\texit 0\nfi\n\n\1:g' \
+ -e 's:\(\${CHOWN}\):# \1:g' \
+ -e 's:\(\${CHGRP}\):true # \1:g' \
+ -e 's:^\(PATH=/\):# \1:g' \
+ -e 's:^\(export PATH\):# \1:g' \
+ -e 's:^if \[ \(`${ID} -u`\):if \[ "${DESTDIR}" = "" -a \1:g' 'install.sh'
+ set +u
+}
+
+package() {
+ set -u
+ cd "${_pkgnick}"
+ install -d "${pkgdir}/usr/share/cups/model"
+ install -d "${pkgdir}/usr/lib/cups/filter"
+ sh -c "export DESTDIR='${pkgdir}'; ./install.sh"
+ set +u
+}
+set +u