summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorg Nagel2015-06-08 13:11:40 +0200
committerGeorg Nagel2015-06-08 13:11:40 +0200
commit8745f93d9ba9f929e8d37516c58a86ee5f6e24d5 (patch)
tree9b0056593d2f5fba933365400e9186515b84b7f8
downloadaur-8745f93d9ba9f929e8d37516c58a86ee5f6e24d5.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD52
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a4bc6ddb683
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = ola-git
+ pkgdesc = The Open Lighting Architecture (OLA) provides a plugin framework for distributing DMX512 control signals on Mac and Linux
+ pkgver = 20150608
+ pkgrel = 1
+ url = http://code.google.com/p/open-lighting/
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ license = GPL2
+ makedepends = git
+ depends = libmicrohttpd
+ depends = cppunit
+ depends = protobuf
+ depends = python2-protobuf
+ depends = python2
+ optdepends = liblo
+ optdepends = avahi
+ optdepends = libusb
+ optdepends = libusb-compat
+ optdepends = libftdi-compat
+ optdepends = openslp
+ provides = ola
+ conflicts = ola
+
+pkgname = ola-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2579bef28ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Georg Nagel <g.schlmm at gmail dot com>
+
+pkgname=ola-git
+pkgver=20150608
+pkgrel=1
+pkgdesc="The Open Lighting Architecture (OLA) provides a plugin framework for distributing DMX512 control signals on Mac and Linux"
+arch=(i686 x86_64)
+url="http://code.google.com/p/open-lighting/"
+license=('LGPL2.1' 'GPL2')
+provides=('ola')
+makedepends=('git')
+depends=('libmicrohttpd' 'cppunit' 'protobuf' 'python2-protobuf' 'python2')
+optdepends=('liblo' 'avahi' 'libusb' 'libusb-compat' 'libftdi-compat' 'openslp')
+conflicts=('ola')
+
+_gitroot="https://github.com/OpenLightingProject/ola.git"
+_gitname="ola"
+# uncomment for 0.9.5
+# _gitcommit="0.9.5"
+
+build() {
+ cd $srcdir
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git checkout master && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot $_gitname
+ fi
+
+ test -n "$_gitcommit" && cd "$srcdir/$_gitname" && git checkout $_gitcommit
+
+ msg "GIT checkout done or server timeout"
+
+ rm -rf "$srcdir/$_gitname-build"
+ cp -r "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+
+ cd "$srcdir/$_gitname-build"
+
+ autoreconf -i
+
+ # since protobuf isnt ported to python 3 we have to choose python 2
+ PYTHON=python2 ./configure --prefix=/usr --enable-python-libs --disable-unittests --disable-fatal-warnings
+
+ make || return 1
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ make DESTDIR="$pkgdir" install || return 1
+}