summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorg Nagel2015-06-08 14:02:25 +0200
committerGeorg Nagel2015-06-08 14:02:25 +0200
commitb01f2c2dfda02b9c4bd8ecee39100be995c900be (patch)
tree419bb4ef3310f5b0f52a86333ce4b47ecb74171a
parentd8a10226dc79c2839b5433f3fdd47231342a3371 (diff)
downloadaur-b01f2c2dfda02b9c4bd8ecee39100be995c900be.tar.gz
next try
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35f119ab5d53..fe5aa9852371 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -21,7 +21,7 @@ pkgbase = ola-git
optdepends = openslp
provides = ola
conflicts = ola
- source = ola-git::git+https://github.com/OpenLightingProject/ola.git
+ source = git+https://github.com/OpenLightingProject/ola.git
sha256sums = SKIP
pkgname = ola-git
diff --git a/PKGBUILD b/PKGBUILD
index 189697d47b63..5ba62f950bf7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=ola-git
pkgver=0.9.5.r406.gaad3ac0
pkgrel=1
pkgdesc="The Open Lighting Architecture (OLA) provides a plugin framework for distributing DMX512 control signals on Mac and Linux"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
url="https://www.openlighting.org/ola/"
license=('LGPL2.1' 'GPL2')
provides=('ola')
@@ -12,18 +12,20 @@ makedepends=('git')
depends=('libmicrohttpd' 'cppunit' 'protobuf' 'python2-protobuf' 'python2')
optdepends=('liblo' 'avahi' 'libusb' 'libusb-compat' 'libftdi-compat' 'openslp')
conflicts=('ola')
-source=("${pkgname}"::'git+https://github.com/OpenLightingProject/ola.git')
+source=("git+https://github.com/OpenLightingProject/ola.git")
# uncomment for 0.9.5
#source=("$pkgname::git+https://github.com/OpenLightingProject/ola#tag=0.9.5")
sha256sums=('SKIP')
+_gitname="ola"
+
pkgver() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${_gitname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${_gitname}"
autoreconf -i
# since protobuf isnt ported to python 3 we have to choose python 2
PYTHON=python2 ./configure --prefix=/usr --enable-python-libs --disable-unittests --disable-fatal-warnings
@@ -31,5 +33,5 @@ build() {
}
package() {
- make -C "${srcdir}/${pkgname}" DESTDIR="${pkgdir}" install
+ make -C "${srcdir}/${_gitname}" DESTDIR="${pkgdir}" install
}