summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorg Nagel2015-06-08 13:40:51 +0200
committerGeorg Nagel2015-06-08 13:40:51 +0200
commitd78f6432ab48b7c34d56022dfe6213d3bfeddb15 (patch)
tree0cc53c7c16ae3cc6f1277e9c834716646c36ada3
parent8745f93d9ba9f929e8d37516c58a86ee5f6e24d5 (diff)
downloadaur-d78f6432ab48b7c34d56022dfe6213d3bfeddb15.tar.gz
rework the pkgbuild
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD49
2 files changed, 20 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a4bc6ddb683..ebc16b7e5a80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = ola-git
pkgdesc = The Open Lighting Architecture (OLA) provides a plugin framework for distributing DMX512 control signals on Mac and Linux
- pkgver = 20150608
+ pkgver = 0.9.5.r406.gaad3ac0
pkgrel = 1
- url = http://code.google.com/p/open-lighting/
+ url = https://www.openlighting.org/ola/
arch = i686
arch = x86_64
license = LGPL2.1
@@ -21,6 +21,8 @@ pkgbase = ola-git
optdepends = openslp
provides = ola
conflicts = ola
+ source = ola-git::git+https://github.com/OpenLightingProject/ola
+ sha256sums = SKIP
pkgname = ola-git
diff --git a/PKGBUILD b/PKGBUILD
index f2579bef28ed..e7349d198e92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,35 @@
# Maintainer: Georg Nagel <g.schlmm at gmail dot com>
pkgname=ola-git
-pkgver=20150608
+pkgver=0.9.5.r406.gaad3ac0
pkgrel=1
pkgdesc="The Open Lighting Architecture (OLA) provides a plugin framework for distributing DMX512 control signals on Mac and Linux"
arch=(i686 x86_64)
-url="http://code.google.com/p/open-lighting/"
+url="https://www.openlighting.org/ola/"
license=('LGPL2.1' 'GPL2')
provides=('ola')
makedepends=('git')
depends=('libmicrohttpd' 'cppunit' 'protobuf' 'python2-protobuf' 'python2')
optdepends=('liblo' 'avahi' 'libusb' 'libusb-compat' 'libftdi-compat' 'openslp')
conflicts=('ola')
-
-_gitroot="https://github.com/OpenLightingProject/ola.git"
-_gitname="ola"
+source=("$pkgname::git+https://github.com/OpenLightingProject/ola")
# uncomment for 0.9.5
-# _gitcommit="0.9.5"
-
-build() {
- cd $srcdir
- msg "Connecting to GIT server...."
-
- if [ -d $_gitname ] ; then
- cd $_gitname && git checkout master && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot $_gitname
- fi
-
- test -n "$_gitcommit" && cd "$srcdir/$_gitname" && git checkout $_gitcommit
-
- msg "GIT checkout done or server timeout"
+#source=("$pkgname::git+https://github.com/OpenLightingProject/ola#tag=0.9.5")
+sha256sums=('SKIP')
- rm -rf "$srcdir/$_gitname-build"
- cp -r "$srcdir/$_gitname" "$srcdir/$_gitname-build"
-
- cd "$srcdir/$_gitname-build"
-
- autoreconf -i
-
- # since protobuf isnt ported to python 3 we have to choose python 2
- PYTHON=python2 ./configure --prefix=/usr --enable-python-libs --disable-unittests --disable-fatal-warnings
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
- make || return 1
+build() {
+ cd "${srcdir}/${pkgname}"
+ autoreconf -i
+ # since protobuf isnt ported to python 3 we have to choose python 2
+ PYTHON=python2 ./configure --prefix=/usr --enable-python-libs --disable-unittests --disable-fatal-warnings
+ make
}
package() {
- cd "$srcdir/$_gitname-build"
- make DESTDIR="$pkgdir" install || return 1
+ make -C "${srcdir}/${pkgname}" DESTDIR="${pkgdir}" install
}