summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2019-05-06 00:42:50 -0300
committerTércio Martins2019-05-06 00:42:50 -0300
commit93d730891d9b6ecdce02afdb649da27583ba7060 (patch)
tree9d72e43f6044295211eb2a54009924b4903fc559
parent2bd1c83ed97be1de5b4b1689fa50d5f27558f89b (diff)
downloadaur-93d730891d9b6ecdce02afdb649da27583ba7060.tar.gz
Update to version 0.1.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD58
-rw-r--r--olive.desktop11
3 files changed, 27 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4306cf4ab26a..b5d5c038ec52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = olive
pkgdesc = Free non-linear video editor
- pkgver = 20181223
- pkgrel = 2
+ pkgver = 0.1.0
+ pkgrel = 1
url = https://www.olivevideoeditor.org/
arch = i686
arch = x86_64
license = GPL3
- makedepends = libicns
+ makedepends = cmake
+ makedepends = qt5-tools
depends = ffmpeg
depends = qt5-multimedia
- conflicts = olive-git
- source = 20181223.tar.gz::https://github.com/olive-editor/olive/archive/20181223.tar.gz
- source = olive.desktop
- sha512sums = b9421faa8bc03855cd51837d1f4a264eea1e32d8a4a2fdbb033f4a5a5622220215c66b52b08ba4eb62788665e065b8bfdf43eae6383f4cf6b8e2bd36c5625f95
- sha512sums = 5c6e6fb0309bfc6a45cde61051df285e8b092545dd56e08aa49c322dd5ce52f8b50f094e5056350222c78e38b1f07a179244beaf8053c923a9fe06d2bff21f3d
+ depends = qt5-svg
+ optdepends = frei0r-plugins
+ optdepends = olive-community-effects-git
+ source = 0.1.0.tar.gz::https://github.com/olive-editor/olive/archive/0.1.0.tar.gz
+ sha512sums = 25889ed40e7dc379eda99bde0c63192e24ef0c7a21b70f3005ecb713f15855727950fbc248160d67d3afe053bfc3222d24e5b6aa8232581b3e2758b3226c86d8
pkgname = olive
diff --git a/PKGBUILD b/PKGBUILD
index 316d47514273..ecd3f3a0e433 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,58 +1,36 @@
# Maintainer: Tércio Martins <echo dGVyY2lvd2VuZGVsQGdtYWlsLmNvbQo= | base64 -d>
pkgname=olive
-pkgver=20181223
-pkgrel=2
+pkgver=0.1.0
+pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Free non-linear video editor"
url="https://www.olivevideoeditor.org/"
license=('GPL3')
-depends=('ffmpeg' 'qt5-multimedia')
-makedepends=('libicns')
-conflicts=('olive-git')
-source=("${pkgver}.tar.gz::https://github.com/olive-editor/olive/archive/${pkgver}.tar.gz"
- "olive.desktop"
- )
-sha512sums=('b9421faa8bc03855cd51837d1f4a264eea1e32d8a4a2fdbb033f4a5a5622220215c66b52b08ba4eb62788665e065b8bfdf43eae6383f4cf6b8e2bd36c5625f95'
- '5c6e6fb0309bfc6a45cde61051df285e8b092545dd56e08aa49c322dd5ce52f8b50f094e5056350222c78e38b1f07a179244beaf8053c923a9fe06d2bff21f3d'
- )
+depends=('ffmpeg' 'qt5-multimedia' 'qt5-svg')
+makedepends=('cmake' 'qt5-tools')
+optdepends=('frei0r-plugins' 'olive-community-effects-git')
+source=("${pkgver}.tar.gz::https://github.com/olive-editor/olive/archive/${pkgver}.tar.gz")
+sha512sums=('25889ed40e7dc379eda99bde0c63192e24ef0c7a21b70f3005ecb713f15855727950fbc248160d67d3afe053bfc3222d24e5b6aa8232581b3e2758b3226c86d8')
prepare() {
- # Configure qmake project
- cd "$srcdir/$pkgname-$pkgver"
- sed -i '1s/^/target.path = \/usr\/bin\n/' $pkgname.pro
- sed -i '1s/^/INSTALLS += target\n/' $pkgname.pro
+ if [ -d build ]
+ then
+ rm -rf build
+ fi
- # Extract icons from the ICNS file
- cd "$srcdir/$pkgname-$pkgver/icons"
- icns2png -x olive.icns
+ mkdir build
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
- qmake $pkgname.pro
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ ../$pkgname
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make INSTALL_ROOT="$pkgdir" install
-
- install -Dm644 "$srcdir/olive.desktop" \
- "$pkgdir/usr/share/applications/olive.desktop"
-
- install -Dm644 "$srcdir/$pkgname-$pkgver/icons/olive_16x16x32.png" \
- "$pkgdir/usr/share/icons/hicolor/16x16/apps/olive.png"
-
- install -Dm644 "$srcdir/$pkgname-$pkgver/icons/olive_32x32x32.png" \
- "$pkgdir/usr/share/icons/hicolor/32x32/apps/olive.png"
-
- install -Dm644 "$srcdir/$pkgname-$pkgver/icons/olive_256x256x32.png" \
- "$pkgdir/usr/share/icons/hicolor/256x256/apps/olive.png"
-
- install -Dm644 "$srcdir/$pkgname-$pkgver/icons/olive_512x512x32.png" \
- "$pkgdir/usr/share/icons/hicolor/512x512/apps/olive.png"
-
- install -Dm644 "$srcdir/$pkgname-$pkgver/icons/olive_1024x1024x32.png" \
- "$pkgdir/usr/share/icons/hicolor/1024x1024/apps/olive.png"
+ cd build
+ make DESTDIR="$pkgdir/" install
}
diff --git a/olive.desktop b/olive.desktop
deleted file mode 100644
index 59eecd9f1caa..000000000000
--- a/olive.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Type=Application
-Name=Olive
-GenericName=Video Editor
-Comment=Free non-linear video editor
-Exec=Olive
-Icon=olive
-Terminal=false
-StartupNotify=false
-Categories=Qt;AudioVideo;AudioVideoEditing;
-Keywords=editing;video;audio;