summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2021-07-28 22:03:18 -0300
committerTércio Martins2021-07-28 22:03:18 -0300
commit396036fa91a8a0da85b62b14594c324478a38e2d (patch)
tree37db190fdda10f76341e00400f61fc7e61f9f23a
parentd9657888c950c25b4418396cd41342d515b674b1 (diff)
downloadaur-396036fa91a8a0da85b62b14594c324478a38e2d.tar.gz
Fix build problem
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f243185a7b91..946cd9e940fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = olive-git
pkgdesc = Free non-linear video editor
- pkgver = continuous.r370.g19eabf28
+ pkgver = continuous.r1090.g5254be3fb
pkgrel = 1
url = https://www.olivevideoeditor.org/
- arch = i686
arch = pentium4
arch = x86_64
license = GPL3
@@ -12,7 +11,7 @@ pkgbase = olive-git
makedepends = ninja
makedepends = qt5-tools
depends = ffmpeg
- depends = openimageio-git
+ depends = openimageio
depends = qt5-multimedia
provides = olive
conflicts = olive
@@ -20,4 +19,3 @@ pkgbase = olive-git
sha512sums = SKIP
pkgname = olive-git
-
diff --git a/PKGBUILD b/PKGBUILD
index bdd76c0eac30..46e04e52ef64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=olive-git
_pkgname=${pkgname%-*}
-pkgver=continuous.r370.g19eabf28
+pkgver=continuous.r1090.g5254be3fb
pkgrel=1
-arch=('i686' 'pentium4' 'x86_64')
+arch=('pentium4' 'x86_64')
pkgdesc="Free non-linear video editor"
url="https://www.olivevideoeditor.org/"
license=('GPL3')
-depends=('ffmpeg' 'openimageio-git' 'qt5-multimedia')
+depends=('ffmpeg' 'openimageio' 'qt5-multimedia')
makedepends=('cmake' 'git' 'ninja' 'qt5-tools')
# Temporarily, the "olive-git" package is incompatible
@@ -27,16 +27,25 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ # Currently the build crashes in the "ffmpegdecoder.cpp" file (-Werror=stringop-overflow).
+ # The build completes normally when this warning is disabled.
+
+ cd $_pkgname
+ sed -i "/Wshadow/a \ \ \ \ -Wno-stringop-overflow" CMakeLists.txt
+}
+
build() {
cd $_pkgname
cmake -GNinja \
-Bbuild \
+ -DCMAKE_CXX_FLAGS=-Wno-stringop-overflow \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
- ninja -C build
+ ninja -C build/
}
package() {
cd $_pkgname
- DESTDIR="$pkgdir" ninja -C build install
+ DESTDIR="$pkgdir" ninja -C build/ install
}