summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2023-02-21 17:10:15 -0300
committerTércio Martins2023-02-21 17:10:15 -0300
commit49b510a215a0e6c394da379f874e756f19b17086 (patch)
tree7a4c31f9ae38fcdb0ae8e46f2209d33375ab2a26
parent8acbe9d8f459f7c57fad5601c66286b285ed703a (diff)
downloadaur-49b510a215a0e6c394da379f874e756f19b17086.tar.gz
Remove dependency "libolivecore-git", revert Qt library to version 5 and add dependency "qt5-x11extras" (because of KDDockWidgets library)
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 23 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5f826c125b5..186aeae9cd4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = olive-git
pkgdesc = Free non-linear video editor
- pkgver = continuous.r2477.gaa6b77f80
+ pkgver = continuous.r2518.g2d83beb2c
pkgrel = 1
url = https://www.olivevideoeditor.org/
arch = x86_64
@@ -8,17 +8,20 @@ pkgbase = olive-git
makedepends = cmake
makedepends = git
makedepends = ninja
- makedepends = qt6-svg
- makedepends = qt6-tools
+ makedepends = qt5-svg
+ makedepends = qt5-tools
depends = ffmpeg4.4
- depends = libolivecore
depends = openimageio
depends = opentimelineio0.14
depends = portaudio
- depends = qt6-base
+ depends = qt5-x11extras
provides = olive
conflicts = olive
source = git+https://github.com/olive-editor/olive.git
+ source = git+https://github.com/KDAB/KDDockWidgets.git
+ source = git+https://github.com/olive-editor/core.git
+ sha512sums = SKIP
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = olive-git
diff --git a/PKGBUILD b/PKGBUILD
index 0ed6e5a80d9f..d3208172c97f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
_pkgname=olive
pkgname=$_pkgname-git
-pkgver=continuous.r2477.gaa6b77f80
+pkgver=continuous.r2518.g2d83beb2c
pkgrel=1
arch=('x86_64')
pkgdesc="Free non-linear video editor"
url="https://www.olivevideoeditor.org/"
license=('GPL3')
-depends=('ffmpeg4.4' 'libolivecore' 'openimageio' 'opentimelineio0.14' 'portaudio' 'qt6-base')
-makedepends=('cmake' 'git' 'ninja' 'qt6-svg' 'qt6-tools')
+depends=('ffmpeg4.4' 'openimageio' 'opentimelineio0.14' 'portaudio' 'qt5-x11extras')
+makedepends=('cmake' 'git' 'ninja' 'qt5-svg' 'qt5-tools')
# Temporarily, the "olive-git" package is incompatible
# with the dependency "olive-community-effects-git".
@@ -19,8 +19,12 @@ makedepends=('cmake' 'git' 'ninja' 'qt6-svg' 'qt6-tools')
provides=('olive')
conflicts=('olive')
-source=('git+https://github.com/olive-editor/olive.git')
-sha512sums=('SKIP')
+source=('git+https://github.com/olive-editor/olive.git'
+ 'git+https://github.com/KDAB/KDDockWidgets.git'
+ 'git+https://github.com/olive-editor/core.git')
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd $_pkgname
@@ -30,6 +34,12 @@ pkgver() {
prepare(){
# Fix link problem with Imath library
echo "target_link_libraries(Imath::Imath INTERFACE OpenEXR::OpenEXR)" >> $_pkgname/cmake/FindOpenEXR.cmake
+
+ cd $_pkgname
+ git submodule init
+ git config submodule.ext/core.url "$srcdir"/core
+ git config submodule.ext/KDDockWidgets.url "$srcdir"/KDDockWidgets
+ git -c protocol.file.allow=always submodule update
}
build() {
@@ -38,7 +48,6 @@ build() {
-Bbuild \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DQT_VERSION_MAJOR=6 \
-DOTIO_DEPS_INCLUDE_DIR=/usr/include/opentimelineio \
-DCMAKE_PREFIX_PATH="/usr/lib/ffmpeg4.4;/usr/include/ffmpeg4.4"
ninja -C build/