summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2023-12-21 01:43:40 +0100
committerAlexander F. Rødseth2023-12-21 01:43:40 +0100
commit0ad2b4079fc9a1942c01d2ecaa9b92ce5feac8da (patch)
treed0d71399fdee1fc38686b9d8c7d36a6e89a014b9
parent7629ed12921fdf58929ef11f1568a0aab19bafa8 (diff)
downloadaur-0ad2b4079fc9a1942c01d2ecaa9b92ce5feac8da.tar.gz
upgpkg: 0.1.17-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e630e09d3d0d..23c7d99a82ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ollama-cuda
pkgdesc = Create, run and share large language models (LLMs) with CUDA
- pkgver = 0.1.16
+ pkgver = 0.1.17
pkgrel = 1
url = https://github.com/jmorganca/ollama
arch = x86_64
@@ -12,9 +12,9 @@ pkgbase = ollama-cuda
makedepends = setconf
provides = ollama
conflicts = ollama
- source = git+https://github.com/jmorganca/ollama#commit=6ee8c80199866f1d1826ca8f8239e7e70c96fab7
+ source = git+https://github.com/jmorganca/ollama#commit=6b5bdfa6c9321405174ad443f21c2e41db36a867
source = ggml::git+https://github.com/ggerganov/llama.cpp#commit=9e232f0234073358e7031c1b8d7aa45020469a3b
- source = gguf::git+https://github.com/ggerganov/llama.cpp#commit=948ff137ec37f1ec74c02905917fa0afc9b97514
+ source = gguf::git+https://github.com/ggerganov/llama.cpp#commit=a7aee47b98e45539d491071b25778b833b77e387
source = sysusers.conf
source = tmpfiles.d
source = ollama.service
diff --git a/PKGBUILD b/PKGBUILD
index 3e55b02c0116..e708304a25cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,17 @@
pkgname=ollama-cuda
pkgdesc='Create, run and share large language models (LLMs) with CUDA'
-pkgver=0.1.16
+pkgver=0.1.17
pkgrel=1
arch=(x86_64)
url='https://github.com/jmorganca/ollama'
license=(MIT)
-_ollamacommit=6ee8c80199866f1d1826ca8f8239e7e70c96fab7 # tag: v0.1.16
+makedepends=(cmake git go setconf)
+_ollamacommit=6b5bdfa6c9321405174ad443f21c2e41db36a867 # tag: v0.1.17
# The git submodule commit hashes are here:
-# https://github.com/jmorganca/ollama/tree/v0.1.16/llm/llama.cpp
+# https://github.com/jmorganca/ollama/tree/v0.1.17/llm/llama.cpp
_ggmlcommit=9e232f0234073358e7031c1b8d7aa45020469a3b
-_ggufcommit=948ff137ec37f1ec74c02905917fa0afc9b97514
+_ggufcommit=a7aee47b98e45539d491071b25778b833b77e387
makedepends=(cmake cuda git go setconf)
provides=(ollama)
conflicts=(ollama)
@@ -55,6 +56,7 @@ build() {
check() {
cd ${pkgname/-cuda}
+ setconf version/version.go 'var Version string' "\"0.0.0\""
go test ./...
}