summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2024-01-28 12:54:20 +0100
committerAlexander F. Rødseth2024-01-28 12:54:20 +0100
commit3a8a152655a666e5e9ee822e239649759269bdeb (patch)
tree294a9b7ec4d06494b3dcc5c85071c1300dff9185
parent4df7eb99c68409d2e0dbd6bedc173255ae033fda (diff)
downloadaur-3a8a152655a666e5e9ee822e239649759269bdeb.tar.gz
upgpkg: 0.1.22-1
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6dfba8e75927..8a52da74cfa3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,9 @@ pkgrel=1
arch=(x86_64)
url='https://github.com/jmorganca/ollama'
license=(MIT)
+_ollamacommit=a47d8b2557259ffc9881817df97fbf6d6824e89e # tag: v0.1.22
# The llama.cpp git submodule commit hash can be found here:
-# https://github.com/jmorganca/ollama/tree/v0.1.21/llm
+# https://github.com/jmorganca/ollama/tree/v0.1.22/llm
_llama_cpp_commit=cd4fddb29f81d6a1f6d51a0c016bc6b486d68def
makedepends=(cmake cuda git go)
provides=(ollama)
@@ -53,7 +54,7 @@ check() {
package() {
install -Dm755 ${pkgname/-cuda}/${pkgname/-cuda} "$pkgdir/usr/bin/${pkgname/-cuda}"
- install -dm700 "$pkgdir/var/lib/ollama"
+ install -dm755 "$pkgdir/var/lib/ollama"
install -Dm644 ollama.service "$pkgdir/usr/lib/systemd/system/ollama.service"
install -Dm644 sysusers.conf "$pkgdir/usr/lib/sysusers.d/ollama.conf"
install -Dm644 tmpfiles.d "$pkgdir/usr/lib/tmpfiles.d/ollama.conf"