summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2023-12-17 23:23:38 +0100
committerAlexander F. Rødseth2023-12-17 23:23:38 +0100
commit7629ed12921fdf58929ef11f1568a0aab19bafa8 (patch)
tree1ae7c9885886ab6f1292188dc2b5bf0fb3baf97d
parentf9635fdc47cd31abbd6dbdf0009ab3a27751b29d (diff)
downloadaur-7629ed12921fdf58929ef11f1568a0aab19bafa8.tar.gz
upgpkg: 0.1.16-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6032ae36e799..e630e09d3d0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ollama-cuda
pkgdesc = Create, run and share large language models (LLMs) with CUDA
- pkgver = 0.1.13
+ pkgver = 0.1.16
pkgrel = 1
url = https://github.com/jmorganca/ollama
arch = x86_64
@@ -12,9 +12,9 @@ pkgbase = ollama-cuda
makedepends = setconf
provides = ollama
conflicts = ollama
- source = git+https://github.com/jmorganca/ollama#commit=cedae0d17a38a23269191bf69f2b2248aa830303
+ source = git+https://github.com/jmorganca/ollama#commit=6ee8c80199866f1d1826ca8f8239e7e70c96fab7
source = ggml::git+https://github.com/ggerganov/llama.cpp#commit=9e232f0234073358e7031c1b8d7aa45020469a3b
- source = gguf::git+https://github.com/ggerganov/llama.cpp#commit=9656026b53236ed7328458269c4c798dd50ac8d1
+ source = gguf::git+https://github.com/ggerganov/llama.cpp#commit=948ff137ec37f1ec74c02905917fa0afc9b97514
source = sysusers.conf
source = tmpfiles.d
source = ollama.service
diff --git a/PKGBUILD b/PKGBUILD
index b1e38224120b..3e55b02c0116 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,16 @@
pkgname=ollama-cuda
pkgdesc='Create, run and share large language models (LLMs) with CUDA'
-pkgver=0.1.13
+pkgver=0.1.16
pkgrel=1
arch=(x86_64)
url='https://github.com/jmorganca/ollama'
license=(MIT)
-_ollamacommit=cedae0d17a38a23269191bf69f2b2248aa830303 # tag: v0.1.13
+_ollamacommit=6ee8c80199866f1d1826ca8f8239e7e70c96fab7 # tag: v0.1.16
# The git submodule commit hashes are here:
-# https://github.com/jmorganca/ollama/tree/v0.1.13/llm/llama.cpp
+# https://github.com/jmorganca/ollama/tree/v0.1.16/llm/llama.cpp
_ggmlcommit=9e232f0234073358e7031c1b8d7aa45020469a3b
-_ggufcommit=9656026b53236ed7328458269c4c798dd50ac8d1
+_ggufcommit=948ff137ec37f1ec74c02905917fa0afc9b97514
makedepends=(cmake cuda git go setconf)
provides=(ollama)
conflicts=(ollama)
@@ -53,12 +53,10 @@ build() {
go build -buildmode=pie -trimpath -mod=readonly -modcacherw -ldflags=-linkmode=external -ldflags=-buildid=''
}
-# "go test" is disabled temporarily because it stopped working,
-# see also: https://github.com/jmorganca/ollama/pull/709#issuecomment-1845583194
-#check() {
-# cd $pkgname
-# go test ./...
-#}
+check() {
+ cd ${pkgname/-cuda}
+ go test ./...
+}
package() {
install -Dm755 ${pkgname/-cuda}/${pkgname/-cuda} "$pkgdir/usr/bin/${pkgname/-cuda}"