summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2024-01-14 13:42:13 +0100
committerAlexander F. Rødseth2024-01-14 13:42:13 +0100
commitafc8cc03e0c5bd6cc5cc686e3a03aa0bd2a0ad1e (patch)
tree3368e4d3bea4d7fd25039727d496fb2a825683cc
parent7e970213e3a3cf6485c04f3b3c54483f53daf1f5 (diff)
downloadaur-afc8cc03e0c5bd6cc5cc686e3a03aa0bd2a0ad1e.tar.gz
upgpkg: 0.1.20-1
-rw-r--r--PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 86aab71e5724..800485ad7ee1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -36,6 +36,12 @@ prepare() {
# Turn LTO on and set the build type to Release
sed -i 's,T_CODE=on,T_CODE=on -D LLAMA_LTO=on -D CMAKE_BUILD_TYPE=Release,g' llm/generate/gen_linux.sh
+
+ # Let gen_linux.sh find libcudart.so
+ sed -i 's,/usr/local/cuda/lib64,/opt/cuda/targets/x86_64-linux/lib,g' llm/generate/gen_linux.sh
+
+ # Let gpu.go find libnvidia-ml.so from the cuda package
+ sed -i 's,/opt/cuda/lib64/libnvidia-ml.so*,/opt/cuda/targets/x86_64-linux/lib/stubs/libnvidia-ml.so*,g' gpu/gpu.go
}
build() {