summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2024-01-20 16:38:54 +0100
committerAlexander F. Rødseth2024-01-20 16:38:54 +0100
commitd54b6cc61fa2240c2fbc1b2d210928a8a72f3f0c (patch)
tree911fc525bf31c53f277ac82a2143bc6b5ba85f40
parente1875748b54e44d045d6414feebe9a7026548942 (diff)
downloadaur-d54b6cc61fa2240c2fbc1b2d210928a8a72f3f0c.tar.gz
upgpkg: 0.1.21-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 9 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2ba9d18c57e..51e0c031d015 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ollama-cuda
pkgdesc = Create, run and share large language models (LLMs) with CUDA
- pkgver = 0.1.20
- pkgrel = 2
+ pkgver = 0.1.21
+ pkgrel = 1
url = https://github.com/jmorganca/ollama
arch = x86_64
license = MIT
@@ -11,8 +11,8 @@ pkgbase = ollama-cuda
makedepends = go
provides = ollama
conflicts = ollama
- source = git+https://github.com/jmorganca/ollama#commit=ab6be852c77064d7abeffb0b03c096aab90e95fe
- source = llama.cpp::git+https://github.com/ggerganov/llama.cpp#commit=328b83de23b33240e28f4e74900d1d06726f5eb1
+ source = git+https://github.com/jmorganca/ollama#commit=4c54f0ddeb997cfefe4716e5631b270112975aab
+ source = llama.cpp::git+https://github.com/ggerganov/llama.cpp#commit=584d674be622fbf1578694ada6e62eebedbfd377
source = sysusers.conf
source = tmpfiles.d
source = ollama.service
diff --git a/PKGBUILD b/PKGBUILD
index 2559ed9aba01..d501e434ab7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
pkgname=ollama-cuda
pkgdesc='Create, run and share large language models (LLMs) with CUDA'
-pkgver=0.1.20
-pkgrel=2
+pkgver=0.1.21
+pkgrel=1
arch=(x86_64)
url='https://github.com/jmorganca/ollama'
license=(MIT)
-_ollamacommit=ab6be852c77064d7abeffb0b03c096aab90e95fe # tag: v0.1.20
+_ollamacommit=4c54f0ddeb997cfefe4716e5631b270112975aab # tag: v0.1.21
# The llama.cpp git submodule commit hash can be found here:
-# https://github.com/jmorganca/ollama/tree/v0.1.20/llm
-_llama_cpp_commit=328b83de23b33240e28f4e74900d1d06726f5eb1
+# https://github.com/jmorganca/ollama/tree/v0.1.21/llm
+_llama_cpp_commit=584d674be622fbf1578694ada6e62eebedbfd377
makedepends=(cmake cuda git go)
provides=(ollama)
conflicts=(ollama)
@@ -36,12 +36,6 @@ prepare() {
# Turn LTO on and set the build type to Release
sed -i 's,T_CODE=on,T_CODE=on -D LLAMA_LTO=on -D CMAKE_BUILD_TYPE=Release,g' llm/generate/gen_linux.sh
-
- # Let gen_linux.sh find libcudart.so
- sed -i 's,/usr/local/cuda/lib64,/opt/cuda/targets/x86_64-linux/lib,g' llm/generate/gen_linux.sh
-
- # Let gpu.go find libnvidia-ml.so from the cuda package
- sed -i 's,/opt/cuda/lib64/libnvidia-ml.so*,/opt/cuda/targets/x86_64-linux/lib/stubs/libnvidia-ml.so*,g' gpu/gpu.go
}
build() {