summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2023-12-07 17:50:20 +0100
committerAlexander F. Rødseth2023-12-07 17:50:20 +0100
commitf9635fdc47cd31abbd6dbdf0009ab3a27751b29d (patch)
tree905dd724b90b0dddae30e17456dec5250b8370b8
parentca44c68c75a5ef1f54384f8da690e45a0f9e839e (diff)
downloadaur-f9635fdc47cd31abbd6dbdf0009ab3a27751b29d.tar.gz
upgpkg: 0.1.13-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffb382dfa088..6032ae36e799 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ollama-cuda
pkgdesc = Create, run and share large language models (LLMs) with CUDA
- pkgver = 0.1.12
- pkgrel = 2
+ pkgver = 0.1.13
+ pkgrel = 1
url = https://github.com/jmorganca/ollama
arch = x86_64
license = MIT
@@ -12,7 +12,7 @@ pkgbase = ollama-cuda
makedepends = setconf
provides = ollama
conflicts = ollama
- source = git+https://github.com/jmorganca/ollama#commit=16a900630616f47ea18026150cad82d5e8008c01
+ source = git+https://github.com/jmorganca/ollama#commit=cedae0d17a38a23269191bf69f2b2248aa830303
source = ggml::git+https://github.com/ggerganov/llama.cpp#commit=9e232f0234073358e7031c1b8d7aa45020469a3b
source = gguf::git+https://github.com/ggerganov/llama.cpp#commit=9656026b53236ed7328458269c4c798dd50ac8d1
source = sysusers.conf
diff --git a/PKGBUILD b/PKGBUILD
index 219394220762..b1e38224120b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=ollama-cuda
pkgdesc='Create, run and share large language models (LLMs) with CUDA'
-pkgver=0.1.12
-pkgrel=2
+pkgver=0.1.13
+pkgrel=1
arch=(x86_64)
url='https://github.com/jmorganca/ollama'
license=(MIT)
-_ollamacommit=16a900630616f47ea18026150cad82d5e8008c01 # tag: v0.1.12
+_ollamacommit=cedae0d17a38a23269191bf69f2b2248aa830303 # tag: v0.1.13
# The git submodule commit hashes are here:
-# https://github.com/jmorganca/ollama/tree/v0.1.12/llm/llama.cpp
+# https://github.com/jmorganca/ollama/tree/v0.1.13/llm/llama.cpp
_ggmlcommit=9e232f0234073358e7031c1b8d7aa45020469a3b
_ggufcommit=9656026b53236ed7328458269c4c798dd50ac8d1
makedepends=(cmake cuda git go setconf)
@@ -53,10 +53,12 @@ build() {
go build -buildmode=pie -trimpath -mod=readonly -modcacherw -ldflags=-linkmode=external -ldflags=-buildid=''
}
-check() {
- cd ${pkgname/-cuda}
- go test ./...
-}
+# "go test" is disabled temporarily because it stopped working,
+# see also: https://github.com/jmorganca/ollama/pull/709#issuecomment-1845583194
+#check() {
+# cd $pkgname
+# go test ./...
+#}
package() {
install -Dm755 ${pkgname/-cuda}/${pkgname/-cuda} "$pkgdir/usr/bin/${pkgname/-cuda}"