summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2023-11-27 21:04:52 +0100
committerAlexander F. Rødseth2023-11-27 21:04:52 +0100
commitfdb3a1e5dd349853568ac0be327acf1c11234f68 (patch)
tree0005b10c533a431ca65f56dc25e86295094b0ec1
parent30b5b25a6cfac8247e3d276065150568be29b89f (diff)
downloadaur-fdb3a1e5dd349853568ac0be327acf1c11234f68.tar.gz
upgpkg: 0.1.12-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d71c94a7c017..da03de6a3c9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ollama-cuda
pkgdesc = Create, run and share large language models (LLMs) with CUDA
- pkgver = 0.1.10
+ pkgver = 0.1.12
pkgrel = 1
url = https://github.com/jmorganca/ollama
arch = x86_64
@@ -10,11 +10,9 @@ pkgbase = ollama-cuda
makedepends = git
makedepends = go
makedepends = setconf
- provides = ollama
- conflicts = ollama
- source = git+https://github.com/jmorganca/ollama#commit=41434a7cdcf33918ae2d37eb23d819ef7361e843
+ source = git+https://github.com/jmorganca/ollama#commit=16a900630616f47ea18026150cad82d5e8008c01
source = ggml::git+https://github.com/ggerganov/llama.cpp#commit=9e232f0234073358e7031c1b8d7aa45020469a3b
- source = gguf::git+https://github.com/ggerganov/llama.cpp#commit=9e70cc03229df19ca2d28ce23cc817198f897278
+ source = gguf::git+https://github.com/ggerganov/llama.cpp#commit=9656026b53236ed7328458269c4c798dd50ac8d1
source = sysusers.conf
source = tmpfiles.d
source = ollama.service
diff --git a/PKGBUILD b/PKGBUILD
index a43f3837253a..33956f584da3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,17 @@
pkgname=ollama-cuda
pkgdesc='Create, run and share large language models (LLMs) with CUDA'
-pkgver=0.1.10
+pkgver=0.1.12
pkgrel=1
arch=(x86_64)
url='https://github.com/jmorganca/ollama'
license=(MIT)
-provides=(ollama)
-conflicts=(ollama)
-makedepends=(cmake cuda git go setconf)
-_ollamacommit=41434a7cdcf33918ae2d37eb23d819ef7361e843 # tag: v0.1.10
+_ollamacommit=16a900630616f47ea18026150cad82d5e8008c01 # tag: v0.1.12
# The git submodule commit hashes are here:
-# https://github.com/jmorganca/ollama/tree/v0.1.10/llm/llama.cpp
+# https://github.com/jmorganca/ollama/tree/v0.1.12/llm/llama.cpp
_ggmlcommit=9e232f0234073358e7031c1b8d7aa45020469a3b
-_ggufcommit=9e70cc03229df19ca2d28ce23cc817198f897278
+_ggufcommit=9656026b53236ed7328458269c4c798dd50ac8d1
+makedepends=(cmake cuda git go setconf)
source=(git+$url#commit=$_ollamacommit
ggml::git+https://github.com/ggerganov/llama.cpp#commit=$_ggmlcommit
gguf::git+https://github.com/ggerganov/llama.cpp#commit=$_ggufcommit
@@ -48,6 +46,7 @@ prepare() {
build() {
cd ${pkgname/-cuda}
export CGO_CFLAGS="$CFLAGS" CGO_CPPFLAGS="$CPPFLAGS" CGO_CXXFLAGS="$CXXFLAGS" CGO_LDFLAGS="$LDFLAGS"
+
go generate ./...
go build -buildmode=pie -trimpath -mod=readonly -modcacherw -ldflags=-linkmode=external -ldflags=-buildid=''
}