summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArne Zachlod2019-11-25 22:34:05 +0100
committerArne Zachlod2019-11-25 22:34:05 +0100
commit2384ae329f44970aa413bf0cfe5b4c39aff2f514 (patch)
tree6d673fb1a303950ff6401c8dbeb1b27f5716c894
parentda3a4f9f63d7813adc792bc393bb7efd66df1915 (diff)
downloadaur-2384ae329f44970aa413bf0cfe5b4c39aff2f514.tar.gz
changed package to building from git
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3eedc279bc5f..72c3790683d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = olsrd
pkgdesc = The olsr.org implementation of the Optimized Link State Routing Protocol.
- pkgver = 0.9.6.2
+ pkgver = v0.9.7.r71.g4ef6d68e
pkgrel = 1
url = http://www.olsr.org/mediawiki/index.php/Olsrd
arch = i686
arch = x86_64
arch = armv6h
+ arch = armv7h
license = custom
makedepends = bison
makedepends = flex
makedepends = gpsd
optdepends = gpsd
- source = https://github.com/OLSR/olsrd/archive/v0.9.6.2.tar.gz
+ source = olsrd::git+https://github.com/OLSR/olsrd.git
source = olsrd.service
- sha256sums = e1e2c1eb4f05fa737bc96fe49c9596984d4059f5209a7149f0a23ac54b99934e
+ sha256sums = SKIP
sha256sums = 321f2e0d30af597a38442eb8f039757767efc5da88205b85cf96819384c94ac7
pkgname = olsrd
diff --git a/PKGBUILD b/PKGBUILD
index 8b8f73f8cda3..e846cd05bd87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,32 @@
# Maintainer: Nimrod Maclomair <nimrod4garoa at gmail dot com>
pkgname=olsrd
pkgrel=1
-pkgver=0.9.6.2
+pkgver=v0.9.7.r71.g4ef6d68e
pkgdesc='The olsr.org implementation of the Optimized Link State Routing Protocol.'
-arch=('i686' 'x86_64' 'armv6h')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url='http://www.olsr.org/mediawiki/index.php/Olsrd'
license=('custom')
depends=()
optdepends=('gpsd')
makedepends=('bison' 'flex' 'gpsd')
-source=('https://github.com/OLSR/olsrd/archive/v0.9.6.2.tar.gz'
+source=("$pkgname"::'git+https://github.com/OLSR/olsrd.git'
'olsrd.service')
-sha256sums=('e1e2c1eb4f05fa737bc96fe49c9596984d4059f5209a7149f0a23ac54b99934e'
+sha256sums=('SKIP'
'321f2e0d30af597a38442eb8f039757767efc5da88205b85cf96819384c94ac7')
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build(){
- cd $pkgname-$pkgver
+ cd $pkgname
make prefix=/usr libdir=/usr/lib/olsrd sbindir=/usr/bin DESTDIR=${pkgdir} build_all
}
package(){
- cd $pkgname-$pkgver
+ cd $pkgname
make prefix=/usr libdir=/usr/lib/olsrd sbindir=/usr/bin DESTDIR=${pkgdir} install_all
mkdir --parents $pkgdir/usr/share/licenses/${pkgname}