summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli2020-03-20 01:45:14 +0100
committerDenis 'GNUtoo' Carikli2020-03-20 01:45:14 +0100
commitc53b5279601f90b124c7fc859e10fb890d92931c (patch)
treeceff33ee5a2061a1d67cfd4fba1800cd11f4b104
downloadaur-c53b5279601f90b124c7fc859e10fb890d92931c.tar.gz
Initial import
Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a906dda816ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = omap-u-boot-utils-git
+ pkgdesc = Various tools to communicate with OMAP bootroms to execute code
+ pkgver = 0.2.0.r40.g2a9344a
+ pkgrel = 1
+ url = https://nmenon.github.io/omap-u-boot-utils/
+ arch = armv7h
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = libusb
+ source = git://github.com/nmenon/omap-u-boot-utils#commit=2a9344ac45f6e4074793182dcaca7b0403dff389
+ sha256sums = SKIP
+
+pkgname = omap-u-boot-utils-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0285796cf916
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Copyright (C) 2020 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+pkgname=omap-u-boot-utils-git
+_pkgname=omap-u-boot-utils
+pkgver=0.2.0.r40.g2a9344a
+pkgrel=1
+pkgdesc="Various tools to communicate with OMAP bootroms to execute code"
+arch=('armv7h' 'i686' 'x86_64')
+url='https://nmenon.github.io/omap-u-boot-utils/'
+license=('GPL2')
+depends=('libusb')
+makedepends=('git')
+_commit=('2a9344ac45f6e4074793182dcaca7b0403dff389')
+source=("git://github.com/nmenon/omap-u-boot-utils#commit=${_commit}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make all usb
+}
+
+package(){
+ cd "${srcdir}/${_pkgname}"
+ install -d -m 755 "${pkgdir}"/usr/bin/
+ install -t "${pkgdir}"/usr/bin/ gpsign pserial pusb tagger ucmd ukermit
+ install -D -m644 COPYING "${pkgdir}"/usr/share/licenses/${_pkgname}/LICENSE
+}