summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRadek Podgorny2017-05-03 12:49:20 +0200
committerRadek Podgorny2017-05-03 12:49:20 +0200
commit0d6088c45f17f793072d6f1b7a8dd75091fc4e75 (patch)
tree8db0c7a7c3d14c61c9c44f4a2e6c229bdf6a5891
downloadaur-0d6088c45f17f793072d6f1b7a8dd75091fc4e75.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8d7658b3cad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = omgf
+ pkgdesc = Use Git Flow with ease – maintain branches, semantic versioning, releases, and changelog with a single command.
+ pkgver = 2.1.1
+ pkgrel = 1
+ url = https://github.com/InternetGuru/omgf
+ arch = any
+ license = GPL-3
+ depends = git
+ source = https://github.com/InternetGuru/omgf/archive/v2.1.1.tar.gz
+ md5sums = bc5b8ef9c3634a39d4250cf3d8ae280c
+
+pkgname = omgf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f77bf54d99d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Radek Podgorny <radek@podgorny.cz>
+
+pkgname=omgf
+pkgver=2.1.1
+pkgrel=1
+pkgdesc="Use Git Flow with ease – maintain branches, semantic versioning, releases, and changelog with a single command."
+arch=('any')
+url='https://github.com/InternetGuru/omgf'
+license=('GPL-3')
+depends=('git')
+source=("https://github.com/InternetGuru/omgf/archive/v${pkgver}.tar.gz")
+md5sums=('bc5b8ef9c3634a39d4250cf3d8ae280c')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure
+ make prefix="$pkgdir/usr"
+ # the prefix= doesn't seem to be working so fix it the hard way
+ sed -i 's|OMGF_DATAPATH=.*|OMGF_DATAPATH=/usr/share/omgf|g' compiled/omgf
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ compiled/install
+}